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1． 认识 UM 软件 

1.1  软件简介 

Universal Mechanism，简称 UM，是一款来自俄罗斯的大型通用多体系统动力

学仿真分析软件，既能模拟多刚体系统，又能模拟多柔体（刚柔耦合/混合）系统。

UM 软件提供了一系列用于机械、铁路、单轨、磁浮、汽车、履带车、油气钻井、

航空航天、核工业和机器人等行业的专业模块和工具。 

UM 软件的创始人是俄罗斯数学家、物理学家和计算科学家德米特里·波戈列

洛夫教授（Prof. Dmitry Pogorelov）。他于 1979 年从莫斯科大学数学力学系毕业，

获得理论力学博士学位，其导师是俄罗斯科学院院士、国际宇航科学院院士、洪堡

奖金获得者 Vladimir Beletskiy 教授（1930-2017）。他曾在德国斯图加特大学访学多

年，回俄后在布良斯克国立技术大学（Bryansk State Technical University，又译作

布良斯克国立理工大学、布良斯克国立工程工艺大学）任教至今，主持创建了计算

力学实验室（www.universalmechanism.com ， www.umlab.ru ），并任首席科学家。 

UM 软件发展历程： 

⚫ 1985 年：启动开发计划； 

⚫ 1989 年：发布 UM 1.0，用于一般多刚体系统动力学计算； 

⚫ 1991 年：增加子系统功能，开始研发铁路车辆模块； 

⚫ 1993 年：增加铁路车辆模块； 

⚫ 1998 年：开始用于 Windows 系统； 

⚫ 2003 年：发布 UM 2.0，增加多变量计算模块和并行计算模块； 

⚫ 2004 年：增加刚柔耦合分析模块，开始研发履带车辆模块； 

⚫ 2005 年：发布 UM 3.0，增加一维列车纵向动力学模块和散粒体模块； 

⚫ 2006 年：发布 UM 4.0，增加三维列车动力学模块、公路车辆模块、轮轨磨

耗模块、履带车辆模块和控制模块； 

⚫ 2009 年：发布 UM 5.0，增加三维自动接触模块； 

⚫ 2010 年，发布 UM 6.0，开始研发铁路车桥耦合模块； 

⚫ 2011 年：增加铁路车桥耦合模块； 

⚫ 2012 年：发布 UM 7.0，增加车轮滚动接触疲劳模块和单轨列车模块； 

⚫ 2015 年：增加传动系模块； 

⚫ 2016 年：发布 UM 8.0，增加柔性轨道和柔性轮对模块，开发了 CONTACT

接口； 

⚫ 2017 年：增加磁浮模块，柔性轨道拓展到单轨和磁浮； 

⚫ 2018 年：单轨列车和磁浮列车支持外部导入柔性轨道梁； 

http://www.universalmechanism.com/
http://www.universalmechanism.com/
http://www.umlab.ru/
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⚫ 2019 年：全新的车轮磨耗及滚动接触疲劳分析工具； 

⚫ 2020 年：全新的图形内核、增加场景模块； 

⚫ 2021 年：发布 UM 9.0，全新的钢轨磨耗及滚动接触疲劳分析工具、增加

气动模块； 

⚫ …… 

 

图 1-1 UM 软件开发核心团队 

 
图 1-2 计算力学实验室 

http://www.universalmechanism.com/
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图 1-3 UM 软件著作权登记证书 

 

http://www.universalmechanism.com/
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图 1-4 UM Input 建模界面

 

图 1-5 UM Simulation 仿真界面  

http://www.universalmechanism.com/
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1.2  模块与功能 

UM 现有模块列表及功能简介见表 1-1。 

表 1-1 UM 模块列表 

序

号 
主模块/附加工具/独立子模块 中文名称 备注 

1 UM Base  基础模块 必选模块 

1.1 UM Base/Control Panel 交互式控制仿真工具 需要模块 1 

1.2 UM Base/Training Ground 履带车辆三维场地工具 需要模块 1和 4 

1.3 UM Base/Ride Comfort 
车辆平稳性与舒适度工

具 

需要模块 1和 3或

4/5/6/7 

2 UM Subsystems 子系统模块 需要模块 1 

3 UM Automotive 公路车辆模块 需要模块 2 

3.1 
UM Automotive/Truck And 

Trailer 
重型卡车 PBS分析工具 专供澳大利亚用户 

4 UM Tracked Vehicle 履带车辆模块 需要模块 2 

5 UM Monorail Train 单轨车辆模块 需要模块 2 

6 UM Maglev 磁浮车辆模块 需要模块 2 

7 UM Loco  铁路车辆模块 需要模块 2 

7.1 
UM Loco/Track Quality 

Estimation 
轨道质量分析工具 专供俄罗斯用户 

7.2 
UM Loco/Multipoint Contact 

Model 
轮轨多点接触模型 需要模块 7 

7.3 
UM Loco/CONTACT add-on 

Interface 
CONTACT 程序接口 

需要模块 7.2和

CONTACT add-on to 

UM 

7.4 
UM Loco/Wheel Profile Wear 

Evolution 
车轮型面磨耗分析工具 需要模块 7.2 

7.5 
UM Loco/Rail Profile Wear 

Evolution 
钢轨型面磨耗分析工具 需要模块 7.2和 14 

8 UM Train 一维列车模块 需要模块 2 

9 UM Train 3D 三维列车模块 需要模块 7和 8 

10 UM Flexible Wheelset 柔性轮对模块 需要模块 7和 16 

11 UM Drilling 钻柱动力学模块 尚未发布 

12 UM Driveline 传动系模块 需要模块 1 

13 UM Pneumatic Systems 气动模块 需要模块 1 

14 UM Experiments 多变量计算模块 需要模块 1 

http://www.universalmechanism.com/
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序

号 
主模块/附加工具/独立子模块 中文名称 备注 

14.1 UM Experiments/Cluster 分布式并行计算工具 需要模块 14 

15 UM Control 控制模块 几个相互独立的子模块 

15.1 UM Control/Matlab Import Matlatb 导入子模块 需要模块 1 

15.2 
UM Control/Matlab 

CoSimulation 
Matlab 联合仿真子模块 需要模块 1和 23 

15.3 
UM Control/User-Defined 

Routines 

用户自定义控制系统子

模块 
需要模块 1 

15.4 UM Control/Block Editor 控制系统编辑器子模块 需要模块 1 

15.5 UM Control/SimInTech Import SimIntech 导入子模块 专供俄罗斯用户 

15.6 
UM Control/SimInTech 

Cosimulation 

SimIntech 联合仿真子

模块 
专供俄罗斯用户 

16 UM FEM  刚柔耦合模块 需要模块 2 

16.1 
UM FEM/Vehicle-Bridge 

Interaction 
铁路车桥耦合分析工具 需要模块 7和 16 

16.2 UM FEM/Monorail Track 单轨车桥耦合分析工具 需要模块 5和 16 

16.3 UM FEM/Maglev Track 磁浮车桥耦合分析工具 需要模块 6和 16 

17 UM Ballast 散粒体模块 需要模块 2 

18 UM Durability 疲劳耐久性分析模块 需要模块 16 

18.1 UM Durability/Loco 
机车疲劳耐久性分析工

具 
专供俄罗斯用户 

18.2 UM Durability/Carriage 
客车疲劳耐久性分析工

具 
专供俄罗斯用户 

18.3 UM Durability/FreightWagon 
货车疲劳耐久性分析工

具 
专供俄罗斯用户 

19 UM 3D Contact 三维接触模块 需要模块 1 

20 UM CAD Interfaces 三维设计软件接口模块 需要模块 1 

21 UM RCF Wheel 车轮滚动接触疲劳模块 需要模块 7.4 

22 UM RCF Rail 钢轨滚动接触疲劳模块 需要模块 7.5 

23 UM COM 第三方软件支持模块 需要模块 1 

24 UM Flexible Railway Track 铁路柔性轨道模块 需要模块 7和 16 

25 UM Scene 三维场景模块 需要模块 1 

26 UM Quick Track 铁路轨道几何模块 需要模块 7或 8 

27 UM Sensors 传感器模块 需要模块 3和 25 

28 UM Video Flow  视频流模块 需要模块 27 

http://www.universalmechanism.com/
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1.3  学前准备工作 

1) 加入 UM 用户 QQ 交流群：262743795，在群文件里下载最新版软件安装

包和教程等资料，如下载不成功，可联系管理员单独发送。 

2) 关注微信公众号：同算科技，及时获取 UM 软件动态，通过微文目录或

关键词获得常见问题的详细解答。 

         

QQ 交流群               微信公众号 

3) 向同算科技微信公众号发送消息：安装或 000，可查看安装方法。 

4) 在 Windows 7/8/10 系统上安装 UM 软件，自 8.3.3.4 起，UM 只发布 64

位版本，不再提供 32 位版本程序。 

5) 首次安装 UM 软件可直接使用 30 天/600 次，之后可以申请延长试用期。

向同算科技微信公众号发送消息：license 或 001，可查看申请方法。 

6) 使用过程中有任何问题可发送电子邮件（如果是具体模型的问题，请将

整个模型文件夹及其调用的文件一起打包）至邮箱：tongsuan@qq.com。 

7) 在学习建模之前，请务必先从 QQ 群的 UM 学习资料文件夹里下载

“UM 培训教程.rar”，并解压到本地计算机的 D 盘（本教程里模型的缺

省路径为“D:\UM 培训教程”）或其他位置，这里包含了本套教程的全

部模型及素材。若无法下载或文件损坏，请私信管理员。 

8) 本教程使用 UM 9.1.1.1 版本，UM 各个版本的界面和基本操作差异不

大，仅在个别地方略有不同。 

9) 本教程循序渐进，分析的模型从简单到复杂，对基本操作的讲解从详细

到简略，请读者务必顺序阅读，夯实基础。 

10) 本教程旨在引导用户快速入门，熟悉 UM 软件建模和仿真的基本方法和

流程，具体的数学和力学知识及计算原理请仔细阅读相关章节的帮助文

档以及专业教科书。 

11) 本教程中所有模型的参数系自编，并不对应实际的物理原型，不可直接

用于科学和工程研究。 

12) 此外，UM 软件自带了很多例子，值得学习借鉴，建议读者一一浏览。 

 

http://www.universalmechanism.com/
https://mp.weixin.qq.com/s?__biz=MzIzNDIyOTMwNw==&mid=100000167&idx=1&sn=113d3db4a35fde7e8fbb613bb5c11cfa&chksm=68f8daf35f8f53e5d4328ef2b20e12206a48b1bde976c7a2b86fbfb58a597b85ce17438c5da2&mpshare=1&scene=23&srcid=1012rOSZcX3h17x3TNkLwfLI#rd
https://mp.weixin.qq.com/s?__biz=MzIzNDIyOTMwNw==&mid=2247483791&idx=1&sn=ce3e4ab2955dbfbc618a9c89a1ee01ea&chksm=e8f8dadbdf8f53cd5fac6a4cfe9f860f9bbf059c48037440a6dddc29153c46a771a867152ec3&mpshare=1&scene=23&srcid=1026SxY14GnZvekDeT2Ef2EK#rd
mailto:tongsuan@qq.com
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2． 多体系统动力学建模与仿真 

 

2.1  实例一：地球仪 

 

 

图 2-1 地球仪模型 

图 2-1 所示为一个常见的地球仪模型，该模型由三个刚体（底座、支架、球

体）组成。惯性参考系原点位于球体几何中心，红色为 X 轴，绿色为 Y 轴，蓝

色为 Z 轴。其中底座固定在地面，没有自由度，支架具有绕底座 X 轴转动的自由

度，球体具有绕支架 Z 轴转动的自由度，因此系统共有两个自由度。 

本例用到的模块：UM Base。 

  

http://www.universalmechanism.com/
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2.1.1 建模 

2.1.1.1  新建模型 

1) 选择开始菜单 → 所有程序 → Universal Mechanism 9 x64 → UM 

Input，运行 UM Input 建模程序（或双击桌面快捷方式 UM Input 图

标），出现如图 2-2 所示界面，这是 UM Input 程序的主菜单和常用工具

栏。 

 
图 2-2 

2) 选择主菜单 File → New object，新建一个 UM 模型，缺省名称为

UmObj0。这时出现 UM Input 建模主窗口，左侧上部是模型树（层次结

构），下部是参数表（参数化建模），右侧为交互界面（输入和修改模型

数据），中间为动画窗口（显示三维模型），如图 2-3 所示。左侧模型树

选中的对象决定了动画窗口和交互界面显示的内容，当前模型没有任何

对象，因此只显示了总体坐标系（惯性参考系，Base0 坐标系），辅助网

格缺省位于 X-Y 平面。 

 

图 2-3 

  

http://www.universalmechanism.com/
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3) 动画窗口顶部有一个工具栏，用于视图操作，可进行缩放、平移和转

动，请读者尝试每个按钮的功能。用鼠标和键盘也可直接调整视图：按

下左键并移动鼠标为转动操作，同时按下左键和 CTRL 键并移动鼠标为

平移操作，滑动鼠标滚轮或同时按下左键和 SHIFT 键并移动鼠标为缩放

操作。 

4) 选择主菜单 File → Save as...，将模型另存为，在弹出窗口删除缺省路

径，直接输入包含模型名称（万向地球仪）的模型路径“D:\UM 培训教

程\我的 UM 模型\地球仪”，当然也可通过按钮 选择其他路径，如图 

2-4。 

     

图 2-4 

5) 点击按钮 Save → 是(Y)，确定在当前目录创建一个 UM 模型。 

 

图 2-5 

6) 这样，我们就创建了一个名为“地球仪”的模型，模型对应一个文件

夹，文件夹名称即为 UM 的模型名称，文件夹里有“input.dat”和

“object.bmp”两个文件，如图 2-6 所示，前者是模型的动力学描述文

件（用于计算），后者是模型缩略图（用于预览）。 

 

图 2-6  

http://www.universalmechanism.com/
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2.1.1.2  底座建模 

1) 选择主菜单 Edit → Read from file，定位到路径“D:\UM 培训教程\几何

素材\地球仪”，选中底座.img，点击按钮打开，如图 2-7 所示。 

 
图 2-7 

2) 这样，我们就导入了地球仪底座的几何图形（Images），如图 2-8 所示。

导入几何图形的目的是增强模型可视化效果，它并不参与动力学计算。 

 

图 2-8 

  

http://www.universalmechanism.com/
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3) 选中左侧模型树中的 Bodies，然后在右侧交互界面点击按钮 ，如图 

2-9。 

 

图 2-9 

4) 这样，我们就创建了一个刚体，系统自动命名为 Body1。在交互界面

Parameters 页面 Image 处的下拉菜单中选择底座，并保持 Visible 选项

为勾选状态，如图 2-10。 

 

图 2-10  

http://www.universalmechanism.com/
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5) 在交互界面顶部 Name 处将该刚体重名为底座，在 Parameters 页面下部

Mass 处定义质量（国际单位：kg）为 1，在 Inertia tensor 处定义刚体相

对其惯性主轴的转动惯量（国际单位：kg·m2）分别为 1，1，1，如图 

2-11。 

备注：每次输入参数或修改参数后，请敲一下回车键。 

 

图 2-11 

6) 选中左侧模型树中的 Joints，然后在右侧交互界面点击按钮 ，如图 

2-12。 

 

图 2-12  
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7) 这样，我们就创建了一个铰，系统自动命名为 Joint1，如图 2-13。 

 

图 2-13 

8) 然后从 Body1 下拉菜单选择 Base0，从 Body2 下拉菜单选择底座，系统

会自动将该铰重命名为 jBase0_底座，如图 2-14。 

 

图 2-14 
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9) 从 Type 下拉菜单中选择 6 d.o.f.，然后在 Coordinates 页面取消勾选三个

平动和三个转动自由度选项（缺省全部为勾选状态），如图 2-15。 

 

图 2-15 

10) 选择菜单 File → Save，保存模型。 

 

通过以上操作，我们就完成了底座的建模： 

✓ 准备几何图形 

✓ 把几何赋给刚体 

✓ 定义刚体的属性 

✓ 描述刚体的运动 
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2.1.1.3  支架建模 

1) 选择主菜单 Edit → Read from file，定位到路径“D:\UM 培训教程\几何

素材\地球仪”，选中支架.img，点击打开，如图 2-16。 

 

图 2-16 

2) 这样，我们就导入了地球仪支架的几何图形（Images），如图 2-17 所

示。导入几何图形的目的是增强模型可视化效果，它并不参与动力学计

算。 

 

图 2-17 
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3) 选中左侧模型树中的 Bodies，右侧交互界面默认显示刚体底座的参数，

如图 2-18，然后在交互界面点击按钮 。这里也可以选中 Bodies，点右

键，选择菜单 Add element to group“Bodies”。 

 

图 2-18 

4) 这样，我们就创建了第二个刚体，系统自动命名为 Body1，在交互界面

Parameters 页面 Image 处的下拉菜单中选择支架，并保持 Visible 选项

为勾选状态，如图 2-19。 

 

图 2-19  
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5) 在交互界面顶部 Name 处将该刚体重名为支架，在 Parameters 页面下部

Mass 处定义质量（国际单位：kg）为 1，在 Inertia tensor 处定义刚体相

对其惯性主轴的转动惯量（国际单位：kg·m2）分别为 1，1，1，如图 

2-20。 

备注：每次输入参数或修改参数后，请敲一下回车键。 

 

图 2-20 

6) 选中左侧模型树中的 Joints，右侧交互界面默认显示铰 jBase0_底座的参

数, 如图 2-21，然后在交互界面点击按钮 。 

 

图 2-21 
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7) 这样，我们就创建了第二个铰，系统自动命名为 Joint1，如图 2-22。 

 

图 2-22 

8) 然后从 Body1 下拉菜单选择底座，从 Body2 下拉菜单选择支架，系统会

自动将该铰重命名为 j 底座_支架，如图 2-23。 

 

图 2-23 
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9) 从 Type 下拉菜单中选择 Rotational，保持缺省设置。表示物体 2 支架相

对物体 1 底座具有一个转动自由度，铰点位于底座的原点，转动轴是底

座的 X 轴，并且支架的原点与底座的原点重合，支架的 X 轴与底座的 X

轴平行（重合），如图 2-24。 

 
图 2-24 

10) 在 Description 页面，我们可以改变 Value 值（转动铰对应为角度），预

览支架相对底座的运动（预览后请记得归零，并敲回车键），如图 

2-25。 

 
图 2-25 
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其实，从第 6-9 步，也可以选中左侧模型树的 Joints，点右键，选择菜单 Add 

element to group“Joints”→ Rotational，然后分别选择 Body1 和 Body2 对应的物

体，如图 2-26。 

 

图 2-26 

11) 选择主菜单 File → Save，保存模型。 

 

通过以上操作，我们就完成了支架的建模： 

✓ 准备几何图形 

✓ 把几何赋给刚体 

✓ 定义刚体的属性 

✓ 描述刚体的运动 
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2.1.1.4  球体建模 

1) 选择主菜单 Edit → Read from file，定位到路径“D:\UM 培训教程\几何

素材\地球仪”，选中球体.img，点击按钮打开，如图 2-27。 

 

图 2-27 

2) 这样，我们就导入了地球仪支架的几何图形（Images），如图 2-28 所

示。导入几何图形的目的是增强模型可视化效果，它并不参与动力学计

算。 

 

图 2-28 
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3) 选中左侧模型树中的 Bodies（其实选中任意一个刚体都行），然后在交互

界面点击按钮 ，如图 2-29。这里也可以选中 Bodies，点右键，选择菜

单 Add element to group“Bodies”。 

 

图 2-29 

4) 这样，我们就创建了第三个刚体，系统自动命名为 Body1，在交互界面

Parameters 页面 Image 处的下拉菜单中选择球体，并保持 Visible 选项

为勾选状态，如图 2-30。 

 

图 2-30  
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5) 在交互界面顶部 Name 处将该刚体重名为球体，在 Parameters 页面下部

Mass 处定义质量（国际单位：kg）为 1，在 Inertia tensor 处定义刚体相

对其惯性主轴的转动惯量（国际单位：kg·m2）分别为 1，1，1，如图 

2-31。 

备注：每次输入参数或修改参数后，请敲一下回车键。 

 
图 2-31 

6) 选中左侧模型树中的 Joints（其实选中任意一个铰都行），然后在交互界

面点击按钮 ，如图 2-32。 

 

图 2-32 
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7) 这样，我们就创建了第三个铰，系统自动命名为 Joint1，如图 2-33。 

 
图 2-33 

8) 然后从 Body1 下拉菜单选择支架，从 Body2 下拉菜单选择球体，系统会

自动将该铰重命名为 j 支架_球体，从 Type 下拉菜单中选择

Rotational，如图 2-34。 

 

图 2-34 
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9) 在 Joint Vector 处对支架和球体都选择 Z 轴，表示物体 2 球体相对物体 1

支架具有一个转动自由度，铰点位于支架的原点，转动轴是支架的 Z

轴，并且球体的原点与支架的原点重合，支架的 Z 轴与底座的 Z 轴平行

（重合），如图 2-35。 

 

图 2-35 

10) 在 Description 页面，我们可以改变 Value 值（转动铰对应为角度），预

览球体相对支架的运动（预览后请记得归零，并敲回车键），如图 

2-36。 

 

图 2-36 
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从第 6-9 步，也可以直接在 Bodies→球体页面，点击按钮 ，选择菜单 Create 

joint → Rotational，然后选择 Body1 对应物体支架，再设置转动轴 Z，如图 2-37。 

 

图 2-37 

11) 选择主菜单 File → Save，保存模型。 

 

通过以上操作，我们就完成了球体的建模： 

✓ 准备几何图形 

✓ 把几何赋给刚体 

✓ 定义刚体的属性 

✓ 描述刚体的运动 

 

至此，已完成所有建模工作。 

 

 

本例详细介绍了 UM 软件导入几何、创建刚体和定义铰的一般方法，后续例

子不再赘述，建议初学者反复练习多次。 

 

  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 28 -             www.tongsuan.cn 
 

2.1.2 仿真 

2.1.2.1  进入仿真程序 

1) 选择 UM Input 程序的主菜单 Object → Simulation 运行仿真程序并自动

加载当前模型（或直接点击工具栏按钮 ）。 

 

图 2-38 

2) 待 UM Simulation 仿真程序运行后，关闭 UM Input 程序（最好不要让

两个程序同时访问一个模型）。 

3) 加载了模型的仿真程序界面如图 2-39 所示，上方为主菜单和常用工具

栏，下方为程序桌面。在程序桌面上自动打开了一个动画窗口，显示当

前模型，可随意调整大小和位置，可关闭也可同时打开多个动画窗口。

请注意，由于 UM Simulation 程序采用了全新的图形引擎 ORGE，其动

画窗口操作与 UM Input 程序略有不同，使用时推荐将平移图标始终保持

为选中状态，则按下鼠标左键移动为平动，按下鼠标中键移动为转动，

滑动鼠标滚轮为缩放。 

 

图 2-39 
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2.1.2.2  设置求解参数 

1) 选择主菜单 Analysis → Simulation，弹出仿真控制面板，如图 2-40。

（或直接点击工具栏按钮 ） 

 

图 2-40 

2) 在 Solver 页面，默认求解器为 Park，将仿真时间 Time 设置为 100（国

际单位：s），如图 2-41。 

 
图 2-41 
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2.1.2.3  设置初始条件 

1) 切换到 Initial conditions 页面，可以看到系统自由度数目为 2，设置第一

个自由度的速度 Velocity 为 1（国际单位：rad/s），如图 2-42。 

备注：每次输入参数或修改参数后，请敲一下回车键。 

 
图 2-42 
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2.1.2.4  执行仿真计算 

1) 点击按钮 Integration，执行仿真，在动画窗口可以看到球体随支架一起

绕底座 X 轴旋转运动，如图 2-43。 

 

图 2-43 

2) 计算完毕后，会自动弹出 Simulation over 提示；若要中途停止仿真，可

点击进度条的按钮 或按 ESC 键。 

 

图 2-44 

3) 在弹出界面点击按钮 Interrupt，终止仿真。 
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2.1.2.5  修改初始条件 

1) 现在回到 Initial conditions 界面，将第二个自由度的速度 Velocity 也设置

为 1（国际单位：rad/s），如图 2-45。 

备注：每次输入参数或修改参数后，请敲一下回车键。 

 

图 2-45 

2) 如果不小心点击了按钮 Close 而将仿真控制面板关闭了，重新通过主菜

单 Analysis → Simulation 或直接点击工具栏按钮 打开即可。 
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2.1.2.6  再次进行仿真 

1) 点击按钮 Integration，再次执行仿真，在动画窗口可以看到球体既随支

架一起绕底座 X 轴旋转运动，又相对支架 Z 轴旋转运动，如图 2-46。 

 

图 2-46 

2) 如果不小心点击了按钮 而将动画窗口关闭了，可通过主菜单 Tools 

→ Animation Window…或工具栏按钮 重新打开。 

2.1.2.7  卸载当前模型 

1) 待计算完毕或中途暂停，在弹出页面点击按钮 Interrupt 终止仿真。 

2) 点击仿真控制面板的 Close 按钮，将其关闭。 

3) 选择主菜单 File → Close，卸载当前模型。 

4) UM Simulation 程序仍在运行，可通过菜单 File → Open 加载其他模

型，进行仿真工作。 
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2.2  实例二：四连杆机构 

 

图 2-47 

图 2-47 所示为一个经典的四连杆机构模型，该模型由四个刚体（机架、曲

柄、连杆和滑块）组成。惯性参考系原点位于机架底面，红色为 X 轴，绿色为 Y

轴，蓝色为 Z 轴。其中机架固定在地面，没有自由度，曲柄具有绕机架 Y 轴转动

的自由度，连杆具有绕曲柄 Y 轴转动的自由度，滑块具有绕连杆 Y 轴转动的自

由度，同时滑块又受到机架的约束只能沿着 X 轴运动，因此形成一个闭环系统，

共有一个独立自由度。 

本例用到的模块：UM Base。 
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2.2.1 建模 

1) 运行 UM Input 程序。 

2) 选择主菜单 File → New object，新建一个 UM 模型。 

3) 选择主菜单 File → Save as…，指定模型路径及名称“D:\UM 培训教程\

我的 UM 模型\四连杆机构”。 

4) 选择主菜单 Edit → Read from file，依次读入“D:\UM 培训教程\几何素

材\四连杆机构”文件夹下的机架.img、曲柄.img、连杆.img 和滑块.img

四个几何图形，如图 2-48。如遇报错，点击 No 即可。 

 

图 2-48 

5) 由于机架没有自由度，所以不必要为其创建刚体，可直接将其赋给

Base0。如图 2-49，先在左侧模型树选中 Object，然后在右侧交互界面

General 页面下方 Scene image 处的下拉菜单中选择几何机架。 

 

图 2-49 
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6) 创建第一个刚体曲柄，从 Image 下拉菜单选择几何曲柄，设置它的质量

（1）和转动惯量（1，1，1）参数，如图 2-50。 

 
图 2-50 

7) 创建第二个刚体连杆，从 Image 下拉菜单选择几何连杆，设置它的质量

（1）和转动惯量（1，1，1）参数及质心坐标（-0.4，0，0），如图 

2-51。 

 

图 2-51 
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8) 创建第三个刚体滑块，从 Image 下拉菜单选择几何滑块，设置质量

（1）和转动惯量（1，1，1）参数及质心坐标（-0.4，0，0），如图 

2-52。 

 

图 2-52 

9) 创建第一个铰，Body1 选择 Base0，Body2 选择曲柄，Type 选择

Rotational，Joint points 分别为（1，0，0.8）和（0，0，0），Joint 

vector 都选择 Y 轴，如图 2-53。表示将曲柄的原点与总体坐标系的点

（1，0，0.8）重合，曲柄绕通过该点与总体坐标系 Y 轴平行的 Y’轴可

以转动，并且曲柄的 Y 轴与之平行（重合）。 

 
图 2-53 
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10) 切换到 Description 页面，设置 Rotation 值为 30（°），作为初始状态。

然后，勾选 Prescribed function of time，然后在弹出对话框点是(Y)，如

图 2-54。 

 
图 2-54 

11) 在最下方数据框输入表达式 omega*t，回车，在弹出界面点击 Accept，

这时新的参数符号 omega 会自动添加到左侧下方的参数符号列表，缺省

值为 0，t 则是系统变量时间。这个表达式用来定义时间函数驱动的转

动，所有带 t 标记的数据框都可以输入显含时间的函数表达式，如图 

2-55。 

 
图 2-55 
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12) 创建第二个铰，Body1 选择曲柄，Body2 选择连杆，Type 选择

Rotational，Joint points 分别为（-0.3，0，0）和（0，0，0），Joint 

vector 都选择 Y 轴，如图 2-56。表示将连杆的原点与曲柄局部坐标系的

点（-0.3，0，0）重合，连杆绕通过该点与曲柄局部坐标系 Y 轴平行的

Y’轴可以转动，并且连杆的 Y 轴与之平行（重合）。 

 

图 2-56 

13) 切换到 Description 页面，将 Value 值设为-55（°），如图 2-57。表示将

连杆相对曲柄转动一定角度作为初始状态。注意对于每一个 Joint，在局

部视图模式下，显示的都是 Joint 连接的第一个物体的局部坐标系。 

 

图 2-57 
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14) 创建第三个铰，Body1 选择连杆，Body2 选择滑块，Type 选择

Rotational，Joint points 分别为（-0.8，0，0）和（0，0，0），Joint 

vector 都选择 Y 轴，如图 2-58。表示将滑块的原点与连杆局部坐标系的

点（-0.8，0，0）重合，滑块绕通过该点与连杆局部坐标系 Y 轴平行的

Y’轴可以转动，并且滑块的 Y 轴与之平行（重合）。 

 
图 2-58 

15) 切换到 Description 页面，将 Value 值设为 25（度），如图 2-59。表示将

滑块相对连杆转动一定角度作为初始状态。注意对于每一个 Joint，在局

部视图模式下，显示的都是 Joint 连接的第一个物体的局部坐标系。 

 

图 2-59 
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16) 创建第四个铰，Body1 选择 Base0，Body2 选择滑块，Type 选择

Translational，Joint points 分别为（0，0，0.6）和（0，0，0），Joint 

vector 都选择 X 轴，如图 2-60。表示将滑块的原点与总体坐标系的点

（0，0，0.6）重合，滑块沿通过该点与总体坐标系 X 轴平行的 X’轴可

以平动，并且滑块的 X 轴与之平行（重合）。 

 

图 2-60 

17) 在动画窗口点右键，选择 Mode → Object，可切换为整体模式，显示当

前模型所有物体。也可点击动画窗口工具栏的 图标进行切换（ ），

如图 2-61。 

 
图 2-61 
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18) 在左侧模型树中，分别点击 Images、Bodies 和 Joints 前面的 图标可以

将其中的元素折叠起来；点击 Summary，在右侧交互界面会有提示模型

是否有逻辑错误（一般的警告可以忽略），如图 2-62。 

 

图 2-62 

19) 选择主菜单 File → Save，保存模型。建议读者养成在建模过程中经常保

存模型的习惯。 

 

至此，我们完成了一个“曲柄滑块”机构（由四连杆演化而来）的建

模。 
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2.2.2 仿真 

1) 选择 UM Input 程序的主菜单 Object → Simulation 运行仿真程序并自动

加载当前模型（或直接点击工具栏按钮 ）。 

2) 待 UM Simulation 仿真程序运行后，关闭 UM Input 程序。 

3) 选择主菜单 Analysis → Simulation，弹出仿真控制面板。（或直接点击工

具栏按钮 或按 F9 键） 

4) 在 Solver 页面，设置求解器为 Park，仿真时间 Time 为 30（s），数据步

长改为 0.005（s），勾选 Computation of Jacobian，如图 2-63。 

 

图 2-63 

5) 切换到 Identifier 页面，给 omega 赋值 1（rad/s），如图 2-64。 
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图 2-64 

6) 切换到 Initial conditions 页面，可以看到有两个铰的初始坐标不为 0，这

是因为我们在建模时设置了一定的初始转角。由于系统存在闭环，因此

有一个铰会被切断，软件自动用约束方程描述，一般不需要处理。 

 

图 2-65 

7) 点击 按钮可以通过“牛顿-拉弗逊”迭代计算出精确的初始条件。可

见，这里显示系统总自由度数目为 0，这是因为曲柄的运动是用时间函

数描述的，那么它的运动是已知的，由此决定了系统中每一个体的运

动。 
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图 2-66 

8) 按钮 Integration，执行仿真，在动画窗口可以看到该机构各构件的运动

情况。 

 
图 2-67 
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9) 计算完毕后，会自动弹出 Simulation over 提示；若要中途停止仿真，可

点击进度条的按钮 或按键 ESC。然后在弹出界面点击按钮 Interrupt，

终止仿真。 

10) 选择主菜单 Tools → Graphical window…打开一个绘图窗口（或点击工

具栏按钮 ），用鼠标调整其大小和位置，如图 2-68。 

 

图 2-68 

11) 选择菜单 Tools → Wizard of variables…打开变量向导（或点击工具栏

按钮 ）。 

12) 在变量向导左侧勾选物体滑块，右侧 Linear variables 页面缺省选择

Coordinate，分量 X，然后点右侧的 图标，创建变量 r:x（滑块），表

示滑块原点相对总体坐标系 X 轴的平动变量，如图 2-69。 
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图 2-69 

13) 将该变量选中并拖入到绘图窗口。 

14) 点击按钮 Integration，再次进行仿真计算，绘图窗口显示结果如图 

2-70。 

 

图 2-70 

  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 48 -             www.tongsuan.cn 
 

2.3  实例三：椭圆规 

 

图 2-71 

图 2-71 所示为一个传统的椭圆规模型，该模型由四个刚体（底板、横滑

标、纵滑标和旋转杆）组成。惯性参考系原点位于底板底面，红色为 X 轴，绿色

为 Y 轴，蓝色为 Z 轴。其中底板固定在地面，没有自由度，横滑标可沿底板 Y

轴向平动，纵滑标可沿底板 X 轴向平动，而旋转杆相对纵、横两个滑标都可转

动。因此形成一个闭环系统，共有一个独立自由度。 

本例用到的模块：UM Base。 
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2.3.1 建模 

1) 运行 UM Input 程序。 

2) 选择主菜单 File → New object，新建一个 UM 模型。 

3) 选择主菜单 File → Save as…，指定模型路径及名称“D:\UM 培训教程\

我的 UM 模型\椭圆规”。 

4) 选择主菜单 Edit → Read from file，依次读入“D:\UM 培训教程\几何素

材\椭圆规”文件夹下的底板.img、横滑标.img、纵滑标.img 和旋转

杆.img 四个几何图形，如图 2-72。 

 

图 2-72 

5) 由于底板没有自由度，所以不必要为其创建刚体，可直接将其赋给

Base0。如图 2-73，先在左侧模型树选中 Object，然后在右侧交互界面

General 页面下方 Scene image 处的下拉菜单中选择几何底板。 

 

图 2-73  
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6) 创建第一个刚体横滑标，从 Image 下拉菜单选择几何横滑标，设置质量

（1）和转动惯量（1，1，1）参数，如图 2-74。 

 
图 2-74 

7) 点击右侧面板上方的按钮 ，复制生成第二个刚体，重命名为纵滑标，

从 Image 下拉菜单选择几何纵滑标，如图 2-75。 

 
图 2-75 
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8) 点击右侧面板上方的按钮 ，复制生成第三个刚体，重命名为旋转杆，

从 Image 下拉菜单选择几何旋转杆，设置质心坐标（0，2，0），如图 

2-76。 

 

图 2-76 

9) 创建第一个铰，Body1 选择 Base0，Body2 选择横滑标，Type 选择

Translational，Joint points 分别为（0，1，0）和（0，0，0），Joint 

vector 都选择 Y 轴，如图 2-77。表示将横滑标的原点与总体坐标系的点

（0，1，0）重合，横滑标沿总体坐标系 Y 轴可以平动，并且横滑标的

Y 轴与之平行（重合）。 

 

图 2-77 
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10) 点击右侧面板上方的按钮 ，复制生成第二个铰，Body2 选择纵滑标， 

Joint points 分别为（0，0，0）和（0，0，0），Joint vector 都选择 X

轴，如图 2-78。表示将横滑标的原点与总体坐标系的原点重合，纵滑标

沿总体坐标系 X 轴可以平动，并且纵滑标的 X 轴与之平行（重合）。 

 

图 2-78 

11) 切换到 Description 页面，勾选将 Prescribed function of time，在弹出窗

口点击是(Y)，然后在下方数据框里输入表达式 sin(t)，回车，定义纵滑

标沿 X 轴做正弦运动，幅值为 1（m），如图 2-79。 

  

图 2-79 
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12) 创建第三个铰，Body1 选择横滑标，Body2 选择旋转杆，Type 选择

Rotational，Joint points 分别为（0，0，0）和（0，1，0），Joint vector

都选择 Z 轴，如图 2-80。表示将旋转杆的点（0，1，0）与横滑标原点

重合，旋转杆绕横滑标的 Z 轴可以转动，并且旋转杆的 Z 轴与之平行

（重合）。 

 

图 2-80 

13) 点击右侧交互界面上方的按钮 ，复制生成第四个铰，Body1 选择纵滑

标，Joint points 分别为（0，0，0）和（0，0，0），如图 2-81。表示将

旋转杆的原点与横滑标的原点重合，旋转杆绕横滑标的 Z 轴可以转动，

并且旋转杆的 Z 轴与之平行（重合）。 

 

图 2-81  
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14) 在动画窗口点右键，选择 Mode → Object，可切换为整体模式，显示当

前模型所有物体。也可点击中间窗口工具栏的 图标进行切换（ ）。 

 
图 2-82 

15) 在左侧模型树中，分别点击 Images、Bodies 和 Joints 前面的 图标可以

将其中的元素折叠起来；点击 Summary，在右侧交互界面会有提示模型

是否有逻辑错误（一般的警告可以忽略）。 

16) 选择主菜单 File → Save，保存模型，然后关闭 UM Input 程序。建议读

者养成在建模过程中经常保存模型的习惯。 

 

至此，我们完成了一个椭圆规的建模。 

  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 55 -             www.tongsuan.cn 
 

2.3.2 仿真 

1) 运行 UM Simulation 仿真程序。 

2) 选择主菜单 File → Open…，弹出文件浏览器，然后定位到路径“D：

\UM 培训模型\我的 UM 模型”，这时可以看到该路径下有三个模型，鼠

标选中任意一个，可以预览模型。选中椭圆规，点击 OK。 

 

图 2-83 

3) 拖动鼠标自由调整动画窗口的大小和位置（一般不要最大化）。 

4) 选择主菜单 Analysis → Simulation，弹出仿真控制面板（或直接点击工

具栏按钮 ）。 

5) 在 Solver 页面，默认求解器为 Park，将仿真时间 Time 设置为 20（s），

如图 2-84。 

6) 选择菜单 Tools → Wizard of variables…打开变量向导（或点击工具栏

按钮 ）。 

7) 在变量向导左侧勾选物体旋转杆，右侧输入局部坐标（0，4，0），选择

Coordinate，分量 V，然后点右侧的 图标，创建变量 r:v（旋转杆），

表示旋转杆局部坐标系中的点（0，4，0）在总体坐标系中的运动轨迹，

如图 2-85。 

 

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 56 -             www.tongsuan.cn 
 

 

图 2-84 

 

图 2-85 

8) 将该变量选中并拖入到动画窗口，然后关闭变量向导。  
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9) 点击按钮 Integration，进行仿真计算，可以看到旋转杆上标记点的运动

轨迹为一个椭圆，默认为灰色显示，如图 2-86。 

 

图 2-86 

10) 暂停仿真，在动画窗口点右键，选择 Position of vector list → Top，这

样在动画窗口上方就显示了该变量，如图 2-87。 

 
图 2-87 
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11) 双击变量 r:v(旋转杆)，将颜色修改为比较醒目的颜色（红色），然后继

续仿真。 

12) 计算完毕后，会自动弹出 Simulation over 提示，如图 2-88，点击确定，

然后在弹出界面点击按钮 Interrupt，终止仿真。 

 

图 2-88 

13) 这里介绍一下录制仿真动画的方法：由于当前版本的图形引擎存在非

ASCII 码兼容性问题，因此请先将 UM Simulation 程序关闭，然后把椭

圆规模型（整个文件夹）复制到一个不含中文字符及空格的目录下，并

以拉丁字母重命名，如：D:\Trammel。 

14) 运行 UM Simulation 程序，打开 D:\Trammel。 

15) 点击动画窗口工具栏第一个按钮 ，选择 Save animation…，如图 

2-89。 

 

图 2-89 

16) 在弹出窗口勾选 Save animation 和 Codec 下拉菜单中选择 Lagarith 

Lossless Codec 或其他选项，然后点击 Apply，如图 2-90。 
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图 2-90 

17) 选择主菜单 Analysis → Simulation，弹出仿真控制面板（或直接点击工

具栏按钮 ），然后点击按钮 Integration，进行仿真计算，计算过程中

不要关闭动画窗口，直到计算完毕，点击确定和 Interrupt，会自动在模

型目录下生成动画文件 motion.avi。 

 

图 2-91 

 
图 2-92 

18) 关闭 UM Simulation 仿真程序（仿真界面的动画窗口不必关，否则下次

打开时需要重新配置）。 
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2.4  实例四：刚柔耦合系统 

 

图 2-93 

 

图 2-93 所示为一个典型的刚柔耦合系统，该模型由三个刚体（支座、刚体

A、刚体 B 和柔性梁）组成。惯性参考系原点位于柔性梁中性层一端，红色为 X

轴，绿色为 Y 轴，蓝色为 Z 轴。其中支座固定在地面，仅作示意，没有自由度，

刚体 A 和刚体 B 都具有沿总体坐标系 Z 轴向平动的自由度，柔性梁与支座铰

接，刚体 A 与柔性梁通过两个弹簧阻尼器连接，刚体 B 和刚体 A 也通过两个弹

簧阻尼器连接。 

本例用到的模块：UM Base、UM FEM。 
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2.4.1 准备柔性体 

1) 运行 UM Input 程序，新建一个 UM 模型，另存为“D:\UM 培训教程\我

的 UM 模型\刚柔耦合系统”。 

2) 复制“D:\UM 培训教程\FEM 素材”下的文件夹 Beam 到“D:\UM 培训

教程\我的 UM 模型\刚柔耦合系统”。Beam 文件夹里包含一个 UM 柔性

体素材文件 input.fum，该文件可以由 ANSYS、ABAQUS 或其他有限元

软件得到。请读者关注微信公众号“同算科技”，发送消息“030”或

“031”，可查看从 ANSYS 或 ABAQUS 导入模型到 UM 的基本方法和流

程，这里不再赘述。 

备注：ANSYS-UM接口可直接生成最终文件 input.fss，而 ABAQUS-UM

接口目前只能生成中间文件 input.fum。 

 
图 2-94 

3) 选择菜单 Tools → Wizard of flexible subsystem，打开柔性体子系统向

导。 

 

图 2-95 
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4) 在图 2-95 界面右侧点击按钮 ，在文件浏览器中定位到路径“D:\UM

培训教程\我的 UM 模型\刚柔耦合系统\Beam”，选中 input.fum，点击

OK，如图 2-96。 

 

图 2-96 

5) 加载 Beam 模型后，这里我们可以在 General 页面看到模型的路径、有

限元软件及版本、单元和节点数目等信息，如图 2-97。 

 
图 2-97 
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6) 切换到 Solution 页面，可以看到在有限元软件里计算得到的 20 阶固有模

态和 12 阶静模态（2*6），选中某一阶模态，点击 Animate 可以预览振

型，如图 2-98。 

 

图 2-98 

7) 勾选 Save to the same directory，勾选 Exclude rigid body modes，设置

截止频率 0.3 Hz，点击按钮 Transform，进行模态正则化，如图 2-99。 

 

图 2-99 
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8) 在弹出界面点击是(Y)。 

 

图 2-100 

9) 然后弹出如下提示，连续点击 OK 即可。 

 

 

图 2-101 

10) 然后点击按钮 Save as，在弹出窗口点击 Save，然后点 OK。这样我们就

转换得到了 UM 仿真所需的格式文件 input.fss，并存于路径“D:\UM 培

训教程\我的 UM 模型\刚柔耦合系统\Beam”，如图 2-102 

   

图 2-102 

11) 关闭柔性体子系统向导 Wizard of flexible subsystem。 
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2.4.2 刚柔耦合系统建模 

1) 回到 UM Input 程序主界面，从路径“D:\UM 培训教程\几何素材\刚柔耦

合系统”依次导入几何素材支座.img，刚体 img 和弹簧.img，将支

座.img 设置为 Scene image，重力方向默认为 Z 轴向下，重力加速度 g = 

-9.81m/s2，如图 2-103。 

 
图 2-103 

2) 创建第一个刚体，命名为刚体 A，从 Image 下拉菜单选择几何刚体，勾

选 Compute automatically，程序会自动根据几何图形计算出物体的质

量、转动惯量和质心位置，如图 2-104。 

 
图 2-104 

3) 复制生成第二个刚体，命名为刚体 B，参数与刚体 A 相同。 
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4) 先在左侧模型树选中 Subsystems，然后在右侧交互界面点击按钮 ，添

加一个子系统，从 Type 下拉菜单中选择 Linear FEM subsystem，如图 

2-105。 

 

图 2-105 

5) 在弹出的文件浏览器窗口，定位到路径“D:\UM 培训教程\我的 UM 模

型\刚柔耦合系统”，选中 Beam，点击 OK，将 Beam 以子系统方式导入

当前 UM 模型，如图 2-106。 

 

图 2-106 
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6) 重命名为柔性梁，在 Image 页面可选择 Simplified 或 Full 模式，可选择

是否显示节点和单元，以及颜色和尺寸，如图 2-107。 

 

图 2-107 

7) 创建第一个铰，Body1 选择 Base0，Body2 选择柔性梁.FEM，Type 为 6 

d.o.f.，Body1 和 Body2 的铰点坐标都是原点，在 Coordinate 页面定义

三个自由度，分别是沿 X 轴平动和绕 Y、Z 轴转动，如图 2-108。 

 

图 2-108 
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8) 复制生成第二个铰，重命名为 jBase0_FEM_2，修改 Body1 和 Body2 的

铰点坐标都为（10，0，0），取消 X 方向平动的自由度，如图 2-109。 

     

图 2-109 

9) 创建第三个铰，Body1 选择 Base0，Body2 选择刚体 A，Type 为

Translational，Body1 的铰点坐标（5，0，0.5），Body2 的铰点坐标为刚

体 A 局部坐标系的原点，定义刚体 A 相对总体坐标系有沿 Z 轴平动的自

由度，如图 2-110。 

 

图 2-110 
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10) 复制生成第四个铰， Body2 选择刚体 B，Type 为 Translational，Body1

的铰点坐标（5，0，1.5），Body2 的铰点坐标为刚体 B 局部坐标系的原

点，刚体 B 相对总体坐标系也具有沿 Z 轴平动的自由度，如图 2-111。 

 

图 2-111 

11) 先选中左侧模型树 Bipolar forces，然后点击右侧按钮 ，添加一个力

元，这种力元只作用于两个物体的两点连线上，力的数值是相对速度或

位移的函数，常用于模拟各种线性和非线性阻尼器，这里我们用它来模

拟简单的弹簧阻尼元件，如图 2-112。 

 

图 2-112 

  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 70 -             www.tongsuan.cn 
 

12) Body1 选择柔性梁.FEM，Body2 选择刚体 A，从 GO 下拉菜单选择弹簧

赋给力元，连接点坐标分别为（4.5，0，0）和（-0.5，0，0），从 Type

下拉菜单选择 Linear，如图 2-113。 

 

图 2-113 

13) 定义刚度系数为 k1（赋值 1.0e6 N/m），阻尼系数为 c1（赋值 1.0e4 

Ns/m），定义弹簧自然长度为 0.5 m，如图 2-114。 

   

图 2-114 

14) 复制生成第二个力元，将 Body1 连接点坐标修改为（5.5，0，0），

Body2 连接点坐标修改为（0.5，0，0），其余不变。 
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15) 复制生成第三个力元，将 Body1 改为刚体 A，Body2 改为刚体 B，连接

点坐标分别为（-0.5，0，0.5）和（-0.5，0，0），定义刚度系数为 k2

（赋值 5.0e5 N/m），阻尼系数为 c2（赋值 4.0e3 Ns/m），如图 2-115。 

 

图 2-115 

16) 复制生成第四个力元，将 Body1 连接点坐标修改为（0.5，0，0.5），

Body2 连接点坐标修改为（0.5，0，0），其余不变。 

17) 点击左侧模型树的 Summary，检查模型是否有逻辑错误。 

18) 保存模型，关闭 UM Input 程序。 

 

至此，我们完成了一个刚柔耦合振动系统的建模。 
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2.4.3 动力学仿真 

1) 运行 UM Simulation 仿真程序，选择菜单 File → Open…，加载模型。

如果在安装软件时勾选了“Associate files *.dat with UM”选项，那么我

们可以通过双击模型文件 input.dat 直接打开模型，如图 2-116。 

 

图 2-116 

2) 拖动鼠标自由调整动画窗口的大小和位置（一般不要最大化），在动画窗

口通过鼠标和工具栏按钮自由调整模型视图。 

 

图 2-117 
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3) 选择主菜单 Tools → Wizard of variables…打开变量向导（或点击工具

栏按钮 ），定义柔性梁 FEM 的垂向位移变量（从点（0，0，0）到点

（10，0，0）每米取一个点，共计 11 个），如图 2-118。 

 
图 2-118 

4) 选择主菜单 Tools → Histogram…，打开一个柱状图窗口，将上一步创

建的 11 个变量全选并拖入其中。 

5) 选择主菜单 Analysis → Simulation，弹出仿真控制面板（或直接点击工

具栏按钮 ）。选择求解器 Park，设置仿真时间为 20（s），数据采样步

长为 0.005（s），勾选选项 Computation of Jacobian。点击 Integration，

开始计算，如图 2-119。 

 

图 2-119 
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6) 等待仿真完成，点击确定和 Interrupt。 

7) 将 11 个变量从变量向导或柱状图窗口拖入仿真控制面板的 Object 

variables 界面；点击按钮 ，将该组变量保存为文件刚柔耦合系

统.var，便于以后计算调用；保持“Automatic saving of variables”为勾

选状态，这样才能以文件形式保存该组变量的计算结果，如图 2-120。 

 

图 2-120 

8) 点击 Integration，执行计算，计算完毕，这样 11 个变量的结果都保存了

下来，如图 2-121。 

 
图 2-121 
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9) 选择主菜单 Tools → Graphical window…，打开一个绘图窗口，将图 

2-121 所有计算结果拖入绘图窗口。 

 
图 2-122 

10) 在绘图窗口左侧列表框选所有曲线，点右键，可以选择输出数据至记事

本或 MS Excel 表格，如图 2-123。 

 

图 2-123 
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11) 选择主菜单 Tools → Table Processor…，打开一个变量处理窗口，将图 

2-121 所有计算结果从仿真控制面板或绘图窗口拖入变量处理窗口，这里

内置了一些数据处理函数，勾选 MaxAbs 和 Std_Dev，如图 2-124。 

 

图 2-124 

12) 选择主菜单 Tools → Statistics…，打开一个统计窗口，将图 2-121 所有

计算结果从仿真控制面板或绘图窗口拖入统计窗口，可查看其功率谱密

度分布图，如图 2-125。 

 

图 2-125 
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13) 现在，请点击仿真控制面板的 Close 按钮，将其关闭，再关闭前面两步

打开的变量处理窗口和统计窗口。 

14) 选择主菜单 Analysis → Static and linear analysis，弹出线性分析控制面

板（或直接点击工具栏按钮 ），如图 2-126。 

 

图 2-126 

15) 勾选左侧的 Frequencies and modes 和右侧的 Eigenvalues，点击按钮

，可计算系统的各阶固有模态的频率及阻尼比，如图 2-127（左侧无

阻尼，右侧有阻尼）。 

 

图 2-127  
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16) 选中某一阶频率，点击按钮 可以在动画窗口观察其模态振型。 

 

图 2-128 

17) 关闭线性分析工具。 
18) 关闭 UM Simulation 程序。 
19) 最后，在计算机上打开模型文件夹，你会发现增加了很多文件，其中名

为 last 的系列文件是最后一次的仿真配置文件，名为刚柔耦合系统的系

列文件则对应计算变量及其结果。 

 

图 2-129 
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2.5  实例五：自动控制系统 

 

图 2-130 

 

图 2-130 所示为一个典型的自动控制系统，该模型由两个刚体（人体和平衡

车）组成。惯性参考系原点位于平衡车走行面，平衡车沿 X 轴有平动自由度，初

始速度 V。人体相对平衡车具有绕 Y 轴转动自由度，初始转动一定角度。在重力

作用下，人体会向下倾，系统靠作用在平衡车上的时变控制力维持平衡。 

本例用到的模块：UM Base、UM Control。 
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2.5.1 机械系统建模 

1) 运行 UM Input 程序，新建一个 UM 模型，另存为“D:\UM 培训教程\我

的 UM 模型\自动控制系统”。 

2) 从路径“D:\UM 培训教程\几何素材\自动控制系统”依次导入几何素材

平衡车.img 和人体.img，如图 2-131。 

 

图 2-131 

3) 创建第一个刚体，命名为平衡车，从 Image 下拉菜单选择几何平衡车，

设置质量为 5，如图 2-132。 

 

图 2-132 
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4) 创建第二个刚体，命名为人体，从 Image 下拉菜单选择几何人体，设置

质量为 75，转动惯量为（0，20，0），质心坐标为（0，0，1），如图 

2-133。 

 

图 2-133 

5) 创建第一个铰，Body1 选择 Base0，Body2 选择平衡车，Type 为

Translational，Body1 的铰点为（0，0，0.2），Body2 的铰点为原点，平

动自由度方向为 X 轴，如图 2-134。 

 

图 2-134 
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6) 创建第二个铰，Body1 选择平衡车，Body2 选择人体， Body1 和 Body2

的铰点坐标都为（0，0，0），转动自由度方向为 Y 轴，如图 2-135。 

    
图 2-135 

7) 先选中左侧模型树 T-forces，然后点击右侧按钮 ，添加一个时变力

元，Body1 选择 Base0，Body2 选择平衡车，在 Force 第一栏定义一个符

号 fx，初始值为 0，如图 2-136。 

 

图 2-136 
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2.5.2 控制系统建模 

1) 选择开始菜单 →  Universal Mechanism 9 x64 → Tools → UM Block 

Editor（或在 UM 安装路径找到程序 BlockEditor.exe，双击运行）。 

2) 从 Inputs and Outputs 模块分别将 Input 和 Output 拖入图板一次，分别

对应控制系统的输入和输出信号，如图 2-137。 

 

图 2-137 

3) 从 Algebra and logic 模块将 Gain 比例环节拖入图板三次，分别双击设置

系数（增益）为 50，20，200，如图 2-138。 

 

图 2-138 
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4) 从 TAC 模块将 Intergator 积分器拖入图板一次，如图 2-139。 

 

图 2-139 

5) 从 TAC 模块将 Real Differential 微分器拖入图板一次，双击设置时间常

数 0.001，如图 2-140。 

 

图 2-140 
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6) 从 Alegbra and logic 模块将 Summator 加法器拖入图板一次，双击设置

输入通道为 3，如图 2-141。 

 

图 2-141 

7) 按图 2-142 所示将各个环节连接起来。 

 

图 2-142 

8) 保存到自动控制系统模型目录下，命名为 control.be，然后关闭 Block 

Editor。 
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2.5.3 动力学仿真 

1) 运行 UM Simulation 仿真程序，选择菜单 File → Open…，加载模型。

也可通过双击模型文件 input.dat 直接打开模型。拖动鼠标自由调整动画

窗口的大小和位置（一般不要最大化），在动画窗口通过鼠标和工具栏按

钮自由调整模型视图，如图 2-143。 

 

图 2-143 

2) 选择主菜单 Tools → External library Interface，弹出外部库向导界面。 

 

图 2-144 
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3) 点击按钮 ，添加一个外部库，如图 2-145。 

 

图 2-145 

4) 点击按钮 ，加载控制系统“D:\UM 培训教程\我的 UM 模型\自动控制

系统\control.be”，如图 2-146。 

 

图 2-146 
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5) 选择主菜单 Tools → Wizard of variables…打开变量向导（或点击工具

栏按钮 ），定义人体绕 Y 轴转动的角度变量，并拖入控制系统的

Inputs 下方的 In1，作为输入信号，如图 2-147。 

 
图 2-147 

6) 双击控制系统的 Outputs 下方的 Out1，从下拉菜单中选择符号 fx，作为

输出信号，如图 2-148。 

 
图 2-148 
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7) 勾选 External library 1，并保存，如图 2-149。 

 
图 2-149 

8) 创建控制力元的矢量 Fv，并拖入动画窗口，如图 2-150。 

 

图 2-150 

9) 选择主菜单 Analysis → Simulation，弹出仿真控制面板。选择求解器

Park，设置仿真时间为 1 s，数据步长为 0.0002 s，容差为 1e-7，勾选选
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项 Computation of Jacobian，如图 2-151。 

 
图 2-151 

10) 切换到 Initial conditons 页面，设置平衡车初始速度 2 m/s，人体相对平

衡车初始角度 0.5 rad，如图 2-152。 

 

图 2-152 
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11) 点击 Integration，开始计算。 

 

图 2-153 

12) 请读者自行尝试不加控制系统的仿真工况，如图 2-154。 

 

图 2-154 
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3． 轨道交通系统动力学建模与仿真 

 

3.1  铁路交通 

 

图 3-1 

图 3-1 所示为一个典型的铁道车辆多刚体系统模型，该模型由一个车体和两

个转向架子系统组成。其中转向架子系统里有一个构架、两个轮对和四个轴箱，构

架与轮对之间有一系悬挂，车体和构架之间有二系悬挂，模型共计 50 个自由度。 

本例用到的模块：UM Base、UM Subsystem、UM Loco。 
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3.1.1 多刚体车辆动力学建模 

3.1.1.1  刚体与铰 

1) 运行 UM Input，新建模型，保存为“D:\UM 培训教程\我的 UM 模型\铁

道车辆多刚体模型”。 

2) 从“D:\UM 培训教程\几何素材\铁道车辆多刚体模型”依次导入建模所

需的几何素材轴箱.img，构架.img，一系弹簧.img，二系弹簧.img 和减

振器.img。 

3) 将轴箱几何重名为轴箱 F，复制生成第二个，命名为轴箱 R，将其绕 Z

轴旋转 180°，如图 3-2。 

 

图 3-2 

4) 创建第一个刚体，命名为轴箱 FL，选择几何轴箱 F，定义质量 50，转动

惯量（1，5，5），如图 3-3。 

 

图 3-3 
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5) 复制生成第二个刚体，命名为轴箱 FR。 

6) 复制生成第三个刚体，命名为轴箱 RR，选择几何轴箱 R。 

7) 复制生成第四个刚体，命名为轴箱 RL。 

8) 创建第五个刚体，命名为构架，选择几何构架，定义质量参数 mframe 

(1605)，转动惯量（1216，1136，2219），质心坐标（0，0，-0.09），如

图 3-4。 

 

图 3-4 

9) 选中左侧模型树 Subsystems，点击右侧按钮 ，添加一个子系统，从下

拉菜单中选择 Wheelset，命名为轮对 F，在 General 页面设置名义半径

0.45，滚动圆跨距之半 0.7465，如图 3-5。 

 

图 3-5 
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10) 切换到 Identifiers 页面，设置轮对质量 1000，侧滚和摇头转动惯量

800，点头转动惯量 100，如图 3-6。 

 

图 3-6 

11) 切换到 Position 界面，设置轮对 F 子系统在总体坐标系中的位置，纵向

前移 1.5，垂向上移 0.45，如图 3-7。 

 
图 3-7 

12) 复制生成第二个子系统，重命名为轮对 R，设置 Position，X = -1.5。 

 

图 3-8 
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13) 创建第一个铰，Body1 选择轮对 F.Wset，Body2 选择轴箱 FL，类型为

Rotational，铰点坐标分别为（0，1.025，0）和（0，0，0），转动轴都

选择 Y 轴，如图 3-9。 

 

图 3-9 

14) 复制生成第二个铰，Body2 更改为轴箱 FR，Body1 铰点坐标修改为

（0，-1.025，0）。 

15) 复制生成第三个铰，Body1 更改为轮对 R.Wset，Body2 更改为轴箱

RR。 

16) 复制生成第四个铰，Body2 更改为轴箱 RL，Body1 铰点坐标修改为

（0，1.025，0） 

17) 创建第五个铰，Body1 选择 Base0，Body2 选择构架，类型为 6 d.o.f.，

铰点坐标分别为（0，0，0.73）和（0，0，0）。切换到整体视图，如图 

3-10。 

 

图 3-10 
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3.1.1.2 一系悬挂 

1) 选中左侧模型树 Linear forces，点击右侧按钮 ，创建第一个一系弹簧

力元，命名为一系弹簧 FL。Body1 选择轴箱 FL，Body2 选择构架，选

择几何一系弹簧，勾选 Automatic computation for 2nd body，输入弹簧

下点和上点坐标（0，0，0.2）和（0，0，0.5），如图 3-11。 

 
图 3-11 

2) 在 Parameters 页面，定义弹簧预压力 fz1，回车，在弹出窗口点

Accept，然后到左侧符号列表双击 fz1，在弹出窗口定义表达式：

9.81*(mcarbody/8+mframe/4)，这时程序会自动创建新的符号参数

mcarbody，保持缺省值为 0 即可。 

 

图 3-12 
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3) 点击 Stiffness matrix 栏的按钮，输入刚度矩阵，如图 3-13，其中 kxy_1

为纵向和横向刚度（9.5e5），kz_1 为垂向刚度（9.0e5）。 

 

图 3-13 

4) 复制生成第二个一系弹簧力元，重命名为一系弹簧 FR，更改 Body1 为

轴箱 FR。 

5) 复制生成第三个一系弹簧力元，重命名为一系弹簧 RR，更改 Body1 为

轴箱 RR。 

6) 复制生成第四个一系弹簧力元，重命名为一系弹簧 RL，更改 Body1 为

轴箱 RL。切换到整体视图，如图 3-14。 

 

图 3-14 
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7) 选中左侧模型树 Bipolar forces，点击右侧按钮 ，创建第一个一系减振

器力元，命名为一系垂向减振器 FL，Body1 选择轴箱 FL，Body2 选择

构架，选择几何减振器。 

8) 定义减振器下点和上点坐标分别为（0.25，0，-0.04），（1.76，1.025，

0.215），选择力元类型 linear，定义阻尼系数 1e4，如图 3-15。 

 

图 3-15 

9) 复制生成第二个一系减振器力元，更改 Body1 为轴箱 FR，修改减振器

上点坐标为（1.76，-1.025，0.215）。 

10) 复制生成第三个一系减振器力元，更改 Body1 为轴箱 RR，修改减振器

下点和上点坐标分别为（-0.25，0，-0.04），（-1.76，-1.025，0.215）。 

11) 复制生成第四个一系减振器力元，更改 Body1 为轴箱 RL，修改减振器

上点坐标为（-1.76，1.025，0.215）。切换到整体视图，如图 3-16。 

 

图 3-16  
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12) 选中左侧模型树 Special forces，点击右侧按钮 ，创建第一个转臂节点

力元，命名为转臂节点 FL，从下拉菜单中选择 Bushing，Body1 选择轴

箱 FL，Body2 选择构架，如图 3-17。 

 

图 3-17 

13) 在 Position\Body1 页面输入连接点坐标（-0.53，0，-0.04），然后勾选

Autodetection; 在 Description 页面定义刚度，纵向平动刚度 1e7，横向

平动刚度 5e6，垂向平动刚度 1e7，绕 X 轴转动刚度 1e4，绕 Z 轴转动刚

度 1e4，如图 3-18。 

     

图 3-18 

14) 复制生成第二个转臂节点力元转臂节点 FR，更改 Body1 为轴箱 FR。 

15) 复制生成第三个转臂节点力元转臂节点 RR，更改 Body1 为轴箱 RR，修

改连接点坐标为（0.53，0，-0.04）。 

16) 复制生成第四个转臂节点力元转臂节点 RL，更改 Body1 为轴箱 RL。  
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3.1.1.3  二系悬挂 

1) 选中左侧模型树 Linear forces，点击右侧按钮 ，命名为二系弹簧 L，

Body1 选择构架，Body2 选择 External，选择几何二系弹簧，勾选

Automatic computation for 2nd body，在 Body1 页面输入弹簧下点和上

点坐标（0，0.94，0）和（0，0.94，0.2），如图 3-19。 

 

图 3-19 

2) 在 Parameters 页面，定义弹簧预压力 fz2，回车，在弹出窗口点

Accept，然后到左侧符号列表双击 fz2，在弹出窗口定义表达式：

9.81*mcarbody/4，如图 3-20。 

     

图 3-20 
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3) 点击 Stiffness matrix 栏的按钮，输入刚度矩阵，如图 3-21，其中 kxy_2

为纵向和横向刚度（1.25e5），kz_2 为垂向刚度（1.5e5），如图 3-21。 

 
图 3-21 

4) 点击 Damping matrix 栏的按钮，输入垂向阻尼系数 10000，如图 3-22。 

 

图 3-22 

5) 复制生成第二个二系弹簧力元二系弹簧 R，修改弹簧下点和上点坐标

（0，-0.94，0）和（0，-0.94，0.2）。 
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6) 选中左侧模型树 Bipolar forces，点击右侧按钮 ，命名为二系横向减振

器 F，Body1 选择构架，Body2 选择 External，选择几何减振器。 

7) 定义减振器左点和右点坐标分别为（0.24，0.24，0.105），（0.24，-0.36，

0.105）, 勾选 Autodetection。 

8) 选择力元类型 Viscous-elastic，定义刚度系数 5e6，阻尼系数 5e4。 

 

图 3-23 

9) 复制生成第二个横向减振器力元二系横向减振器 R，修改减振器两个连

接点坐标分别为（-0.24，-0.24，0.105），（-0.24，0.36，0.105）。 
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10) 复制力元，重命名为抗蛇行减振器 L，修改减振器两个连接点坐标分别

为（-0.16，1.315，-0.17），（0.54，1.315，-0.17）。 

11) 更改力元类型为 Nonlinear viscous-elastic。 

 
图 3-24 

12) 点击 Spring 栏的按钮 ，定义减振器串联接头刚度 1e7 (N/m)（横坐标

为弹簧变形，纵坐标为弹簧力）。 

 

图 3-25 
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13) 点击 Damper 栏的按钮 ，定义减振器非线性特性（横坐标为相对速

度）。 

 

图 3-26 

14) 复制力元，重命名为抗蛇行减振器 R，修改减振器两个连接点坐标分别

为（-0.16，-1.315，-0.17），（0.54，-1.315，-0.17）。 

15) 点击 切换到整体视图，点击中间动画窗口工具栏图标 ，从下拉菜单

选择 Show all，可看到每个元素都有相应标记。 

 

图 3-27 

 

至此，我们完成了转向架系统一系和二系的建模，记得保存一下。 
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3.1.1.4 整车装配 

1) 左侧选中模型树 Object，在右侧 General 页面点击按钮 Transform into 

subsystem，这样就把一个转向架模型压缩成了一个子系统，便于整体操

作。 

 

图 3-28 

2) 重命名为转向架 F，在 Position 定义 X 平动 9。 

 

图 3-29 

3) 复制生成第二个子系统，重命名为转向架 R，Position 定义 X 平动-9。 

4) 点击 Edit subsystem，进入转向架 R 子系统。 

5) 将构架几何绕 Z 轴旋转 180°。 
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图 3-30 

6) 点开 Bipolar forces，修改第一个抗蛇行减振器力元的连接点坐标为

（0.16，1.315，-0.17），（-0.54，1.315，-0.17）；修改第二个抗蛇行减振

器力元的连接点坐标为（0.16，-1.315，-0.17），（-0.54，-1.315，-0.17）。 

7) 点击 Accept，完成修改，退出子系统。 

8) 从“D:\UM 培训教程\几何素材\铁道车辆多刚体模型”导入几何素材车

体。 

9) 在左侧参数符号列表区点右键，选择菜单 Add from subsystem…，从列

表中选择转向架 F 子系统里的 mcarbody 参数，将其设置为 40000

（kg），弹出提示，点击 OK，这样将两个转向架子系统里的 mcarbody

参数也都赋值 40000，如图 3-31。 

   

图 3-31 
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图 3-32 

10) 创建车体刚体，定义质量 mcarbody，转动惯量（1e5，2e6，2e6），质心

坐标（0，0，1.75）；点击按钮 ，创建一个六自由度铰。 

 

图 3-33 

11) 最后，我们需要将车体和两个转向架子系统建立连接。在二系力元建模

时，还没有车体这个物体，因此所有的 Body2 都选择为一个虚拟物体

External，两个连接点的坐标都在 Body1 坐标系中定义的。在左侧模型

树选择 Connection，右侧交互界面选中任意一个力元，点右键，选择

Assign to all，然后选择车体局部坐标系原点（其实车体上任意点都

行），这样就用车体替换了子系统里的 External 虚拟体。 
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图 3-34 

     

图 3-35 

12) 点击 Summary，检查是否有逻辑错误，保存模型，关闭 UM Input 程

序。  
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3.1.2 多刚体车辆动力学仿真 

1) 运行 UM Simulation 程序，加载铁道车辆多刚体模型。自由调整动画窗

口大小、位置和视图方向。 

 

图 3-36 

2) 打开仿真控制面板，选择 Park 求解器，设置仿真距离 1500m，设置数据

采样步长为 0.005s，勾选 Computation of Jacobian。 

 

图 3-37 
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3) 切换到 Railvehicle→Track→Model and parameters 页面，设置轨底坡

0.025rad，轮轨型面坐标原点横向间距 6.05mm，轨道模型为无质量钢

轨，下方可定义轨道整体刚度和阻尼。 

 
图 3-38 

4) 切换到 Track→Macrogeometry 页面，选择 Curve 类型轨道，定义直线

段长度 60m，缓和曲线长度 440m，圆曲线长度 500m，圆曲线半径

5500m，超高 0.15m。 

 

图 3-39 
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5) 切换到 Track → Irregularities 页面，选择 Uneven，不平顺类型为

From file，然后分别设置左、右轨垂向和横向的不平顺，如图 3-40。 

 
图 3-40 

6) 切换到 Wheel/Rail → Wheels → Profiles 页面，点击 按钮，将

Chinese LMA.wpf 车轮踏面添加进来，然后将其选中，点右键，选择菜

单 Assign to all，赋给每个车轮。 

 
图 3-41 
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7) 切换到 Wheel/Rail → Rails 页面，点击 按钮，将 CN_Rail_60.rpf 钢

轨外形添加进来，然后将其选中，点右键，选择菜单 Assign to both 

rails，赋给左右轨。 

 

图 3-42 

8) 切换到 Rail vehicle → Contact → Contact forces 页面，选择 FASTSIM

蠕滑模型。 

 

图 3-43 
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9) 切换到 Rail vehicle → Speed 页面，选择匀速模式 v=const，并设置速度

控制力作用于车体，如图 3-44。 

 

图 3-44 

10) 切换到 Identifiers → List of identifiers 页面，设置车辆初始速度 v0 为

300，在弹出窗口点击 OK，如图 3-45。 

 

图 3-45 
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11) 选择主菜单 Tools→Options，或直接在工具栏上修改车辆初始速度单位

为 km/h。这里的单位只对 v0 参数有效，计算结果均为国际单位（m，

rad ，kg，s，N），如图 3-46。 

 
图 3-46 

12) 打开变量向导，在 Wheel/Rail 页面创建第一轮对左轮脱轨系数变量，并

拖入一个绘图窗口。 

 

图 3-47 
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13) 点击工具栏图标 ，打开接触斑动画窗口，勾选 Contact patches，并

调整大小和位置； 

14) 点击工具栏图标 ，打开轮轨接触力动画窗口。 

15) 在模型动画窗口，将鼠标光标移动到车体上，点右键，选择菜单 

Camera follows (车体)可使窗口始终跟随车体，如图 3-48。 

    

图 3-48 

16) 点击仿真控制面板 Integration 按钮开始仿真。 

17) 在绘图窗口点右键，选择菜单 Show all，可自动调节以适应窗口。 

 

图 3-49 

  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 117 -             www.tongsuan.cn 
 

18) 在轮轨接触力动画窗口，可设置矢量箭头单位长度表示力的大小，缺省

状态动画窗口里最近处为一位轮对，可根据个人习惯转动视角。 

 

图 3-50 

19) 仿真过程如图 3-51，如果将动画窗口最小化，计算会非常快。 

 

图 3-51 
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3.1.3 构建刚柔耦合车辆系统 

本节介绍将刚性构架替换为柔性构架的方法，操作如下： 

1) 复制前一节建立的铁道车辆多刚体模型（整个文件夹），重命名为铁道车

辆刚柔耦合模型。 

2) 将“D:\UM 培训教程\FEM 素材”目录下的 Frame 文件夹整体复制到

“D:\UM 培训教程\我的 UM 模型\铁道车辆刚柔耦合模型”。 

 
图 3-52 

3) 运行 UM Input 程序，加载刚柔耦合车辆模型。 

4) 在左侧模型树选中子系统转向架 F，然后在右侧面板点击 Edit 

subsystem，进入前转向架子系统。 

 

图 3-53 
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5) 删除刚体构架和相应的铰。 

 

图 3-54 

6) 添加一个子系统，选择 Linear FEM Subsystem，定位到路径“D:\UM 培

训教程\我的 UM 模型\铁道车辆刚柔耦合模型”，选中 Frame，点 OK，

导入柔性体，命名为构架。 

 

图 3-55 
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7) 在构架子系统 Position 页面，设置高度 0.73m，在 Image 页面可以设置

显示模式。 

 

图 3-56 

8) 将所有一系力元的第二个 Body 设置为构架.frame。 

 

图 3-57 
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9) 将所有二系力元的第一个 Body 设置为构架.frame。 

 

图 3-58 

10) 点击 Summary，如果某些力元没有设置作用的物体，会有 Error 提示，

根据提示找到这些力元，并完成设置即可。 

 

图 3-59 

11) 点击 Accept，保存对转向架 F 子系统的修改，并退出子系统。 

 

图 3-60 

12) 保存模型，关闭 UM Input 程序，然后就可以用 UM Simulation 进行仿

真了。 
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3.2 单轨交通 

 

图 3-61 

图 3-61 所示为一个典型的跨座式单轨车辆模型，该模型由一个车体和两个转

向架子系统组成。其中转向架子系统里有一个构架、四个走行轮、四个导向轮和两

个稳定轮，轮胎作为一系悬挂，车体和构架之间有二系悬挂，模型共计 38 个自由

度。 

本例用到的模块：UM Base、UM Subsystem、UM Monorail Train。 
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3.2.1 跨座式单轨车辆动力学建模 

3.2.1.1  刚体与铰 

1) 运行 UM Input，新建模型，保存为“D:\UM 培训教程\我的 UM 模型\跨

座式单轨车辆模型”。 

2) 从“D:\UM 培训教程\几何素材\跨座式单轨车辆模型”依次导入建模所

需的几何素材构架.img，走行轮.img，导向轮 img，稳定轮.img，空气弹

簧.img 和减振器.img。 

 

图 3-62 

3) 创建第一个刚体，命名为构架，选择几何构架，定义质量 2000，转动惯

量（1000，800，1200），质心坐标为（0，0，0.2）。 

 

 
图 3-63 
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4) 创建第二个刚体，命名为走行轮 FL，选择几何走行轮，定义质量 40，

转动惯量（1.5，3.0，1.5）。 

 

图 3-64 

5) 将刚体走行轮 FL 复制三次，分别重命名为走行轮 FR、走行轮 RR 和走

行轮 RL。 

6) 创建第六个刚体，命名为导向轮 FL，选择几何导向轮，定义质量 20，

转动惯量（0.5，1.0，0.5）。 

 
图 3-65 

7) 将刚体导向轮 FL 复制三次，分别命名为导向轮 FR、导向轮 RR 和导向

轮 RL。 

8) 创建第十个刚体，命名为稳定轮 L，选择几何稳定轮，定义质量 20，转

动惯量（0.5，1.0，0.5）。 
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图 3-66 

9) 将刚体稳定轮 L 复制一次，命名为稳定轮 R。 

10) 创建第一个铰，Body1 选择 Base0，Body2 选择构架，类型为 6 d.o.f.，

铰点坐标都为各自的原点，无需修改。 

 

图 3-67 
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11) 创建第二个铰，Body1 选择构架，Body2 选择走行轮 FL，类型为

Rotational，两个物体铰接点坐标分别为（0.8，0.17，0.4）和（0，0，

0），转动轴都为 Y 轴（0，1，0）。 

 

图 3-68 

12) 在 Joint force 页面选择 Expression 类型的力元，定义 F=M_control（对

于转动铰，这里的 F 表示转矩），用于仿真速度控制。 

     
图 3-69 
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13) 复制生成第三个铰，Body2 更改为走行轮 FR，Body1 的铰接点坐标为

（0.8，-0.17，0.4）。 

14) 复制生成第四个铰，Body2 更改为走行轮 RR，Body1 的铰接点坐标为

（-0.8，-0.17，0.4）。 

15) 复制生成第五个铰，Body2 更改为走行轮 RL，Body1 的铰接点坐标为

（-0.8，0.17，0.4），切换到整体模式。 

 

图 3-70 

16) 创建第六个铰，Body1 选择构架，Body2 选择导向轮 FL，类型为

Rotational，两个物体的铰接点坐标分别为（0.85，0.745，-0.335）和

（0，0，0），转动轴分别为 Z 轴负向（0，0，-1）和 Y 轴（0，1，0）。

在 Description 页面可预览该自由度，确保导向轮铰坐标增加时对应车辆

前进方向。 

 

图 3-71 

17) 复制生成第七个铰，Body2 更改为导向轮 FR，Body1 的连接点为

（0.85，-0.745，-0.335），Body1 的转动轴为 Z 轴正向（0，0，1），与左

侧相反。 
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18) 复制生成第八个铰，Body2 更改为导向轮 RR，Body1 的连接点为（-

0.85，-0.745，-0.335）。 

19) 复制生成第九个铰，Body2 更改为导向轮 RL，Body1 的连接点为（-

0.85，0.745，-0.335），Body1 的转动轴为 Z 轴负向（0，0，-1），与右侧

相反。 

 

图 3-72 

20) 复制生成第十个铰，Body2 更改为稳定轮 L，Body1 的连接点为（0，

0.745，-1.3），Body1 的转动轴为 Z 轴负向（0，0，-1）。 

21) 复制生成第十一个铰，Body2 更改为稳定轮 R，Body1 的连接点为（0，

-0.745，-1.3），Body1 的转动轴为 Z 轴正向（0，0，1），与左侧相反。 

 
图 3-73 

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 129 -             www.tongsuan.cn 
 

3.2.1.2  悬挂力元 

1) 选中左侧模型树 Special forces，点击右侧按钮 ，从下拉菜单中选择

Tyre 轮胎力元，Body1 选择 Base0，Body2 选择走行轮 FL。 

 

图 3-74 

2) 将轮胎力元走行轮 FL 复制 9 次，依次选择 Body2 为走行轮 FR、走行轮

RR、走行轮 RL、导向轮 FL、导向轮 FR、导向轮 RR、导向轮 RL、稳

定轮 L 和稳定轮 R（并无严格的先后顺序）。 

3) 选中左侧模型树 Linear forces，点击右侧按钮 ，创建左侧的空气弹簧

力元，Body1 选择构架，Body2 选择 External，选择几何空气弹簧，勾

选 Automatic computation for 2nd body，输入弹簧下点和上点坐标（0，

0.95，0.6）和（0，0.95，0.8）。 

 

图 3-75 
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4) 在 Parameters 页面，定义弹簧预压力 fz2，回车，在弹出窗口点

Accept，然后到左侧符号列表双击 fz2，在弹出窗口定义表达式：

9.81*mcarbody/4，这时程序会自动创建新的符号参数 mcarbody，保持

缺省值为 0。 

 

图 3-76 

5) 点击 Stiffness matrix 栏的按钮，输入刚度矩阵，如图 3-77，其中 kxy_2

为纵向和横向刚度（1.25e5），kz_2 为垂向刚度（1.5e5）。 

 
图 3-77 

6) 复制生成右侧的空气弹簧力元，修改弹簧下点和上点坐标（0，-0.95，

0.6）和（0，-0.95，0.8）。 
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7) 选中左侧模型树 Bipolar forces，点击右侧按钮 ，创建左侧的减振器，

Body1 选择构架，Body2 选择 External，选择几何减振器，勾选

Autodetection，Body1 连接点坐标（0.25，0.1，0.6），Body2 连接点坐

标（0.25，0.4，0.9）。 

8) 从下拉菜单选择力元 Points(numeric)，横坐标设为速度 v，勾选压缩为

正 Positive：compression，点击 Force 栏按钮 打开曲线编辑器，定义

非线性的阻尼特性，如图 3-78。 

 

图 3-78 

9) 复制生成右侧的减振器，修改 Body1 连接点坐标（-0.25，-0.1，0.6），修

改 Body2 连接点坐标（-0.25，-0.4，0.9）。 
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10) 选中左侧模型树 Special forces，点击右侧按钮 ，添加一个力元，选择

类型 Bushing，Body1 选择构架，Body2 选择 External，勾选

Autodetection，在 Body1 界面设置连接点(0，0，0.5)，在 Description 页

面设置线性牵引刚度 CX=1e7。 

    

图 3-79 

11) 复制生成第二个 Bushing 力元，在 Body1 界面设置连接点(0，0，0.7)，

在 Description 页面设置线性抗侧滚刚度 CAX=1e6。 

    

图 3-80 
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12) 复制生成第三个 Bushing 力元，在 Body1 界面设置连接点(0，0，0.65)，

在 Description 页面下拉菜单选择类型 Generalized，然后到 Fy 页面，选

择 Point(numeric)，横坐标设为位移 x，勾选压缩为正 Positive：

compression。 

    

图 3-81 

13) 点击 Force 栏按钮 打开曲线编辑器，点击按钮 ，读取“D:\UM 培训

教程\曲线素材”路径下的横向止挡.crv 文件，其非线性特性如图 3-82。 

 

图 3-82 

至此，我们完成了转向架系统的建模，记得保存一下。  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 134 -             www.tongsuan.cn 
 

3.2.1.3  整车装配 

1) 左侧选中模型树 Object，在右侧 General 页面点击按钮 Transform into 

subsystem，这样就把一个转向架模型压缩成了一个子系统，便于整体操

作。 

 

图 3-83 

2) 重命名为转向架 F，在 Position 定义 X 平动 5m。 

 
图 3-84 

3) 复制生成第二个子系统，重命名为转向架 R，Position 定义 X 平动-5 

m。 
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4) 从“D:\UM 培训教程\几何素材\跨座式单轨车辆模型”导入几何素材车

体。 

5) 在左侧参数符号列表区点右键，选择菜单 Add from subsystem…，从列

表中选择转向架 F 子系统里的 mcarbody 参数，将其设置为 15000kg，

弹出提示，点击 OK，这样将两个转向架子系统里的 mcarbody 参数也都

赋值 15000 kg。 

     

图 3-85 

    

图 3-86 
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6) 创建车体刚体，定义质量 mcarbody，转动惯量（2e4，2e5，2e5），质心

坐标（0，0，1.75）；点击按钮 ，创建一个六自由度铰。 

     

图 3-87 

7) 然后，我们需要将车体和两个转向架子系统建立连接。在二系力元建模

时，还没有车体这个物体，因此所有的 Body2 都选择为一个虚拟物体

External，两个连接点的坐标都在 Body1 坐标系中定义的。在左侧模型

树选择 Connection，右侧交互界面选中任意一个力元，点右键，选择

Assign to all，然后选择车体局部坐标系，这样就用车体替换了子系统里

的 External 虚拟体。 

 

图 3-88 
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图 3-89 

8) 最后，在左侧模型树选中 Object，右侧面板 General 界面 Comments 处

输入备注 Monorail，这样仿真程序才能调用单轨模块的功能，否则是汽

车模块。 

 

图 3-90 

9) 点击 Summary，检查是否有逻辑错误，保存模型，关闭 UM Input 程

序。 
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3.2.2 跨座式单轨车辆动力学仿真 

1) 运行 UM Simulation 程序，加载跨座式单轨车辆模型。自由调整动画窗

口大小、位置和视图方向。 

 

图 3-91 

2) 打开仿真控制面板，选择 Park 求解器，设置仿真时间 30s，设置数据采

样步长为 0.005s，勾选 Computation of Jacobian。 

 

图 3-92 
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3) 切换到 Monorail train → Tires，点击按钮 ，添加“D:\UM 培训教程\

轮胎模型”路径下的三个轮胎模型。 

 

图 3-93 

4) 在页面下方点右键，选择菜单 Assign to all driving wheels → 走行

轮.tr，这样就给每一个走行轮定义了轮胎模型。 

 

图 3-94 
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5) 在页面下方点右键，选择菜单 Assign to all guiding wheels → 导向

轮.tr，这样就给每一个导向轮定义了轮胎模型。 

6) 在页面下方点右键，选择菜单 Assign to all stabilizing wheels → 稳定

轮.tr，这样就给每一个稳定轮定义了轮胎模型。 

7) 切换到 Options and parameters 页面，设置导向面和稳定面的横向距离

之半均为 0.45m。 

 

图 3-95 

8) 切换到 Tools 页面，从下拉菜单选择 Beam section profile。 

 

图 3-96 
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9) 然后点击 Data Input/Edit 栏的 按钮，弹出曲线编辑器，点击曲线编辑

器工具栏按钮 ，读取“D:\UM 培训教程\曲线素材”路径下的跨座式

单轨梁.crv 文件。 

 

图 3-97 

10) 切换到 Speed 页面，选择 v=0 模式。 

 
图 3-98 
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11) 点击 Integration，进行静平衡计算，经过约 5s，程序提示“Test succed. 

Accept results?”,点击是(Y)。 

 

图 3-99 

12) 在 Monorail Train | Tires 页面，可以看到各个轮胎的预压力与压缩量；

在 Initial conditions 页面，可以看到每个物体在各方向的位移量（相对

与建模位置）。 

   

图 3-100 

13) 切换到 Speed 页面，选择 v=const 模式。 

 
图 3-101 

 

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 143 -             www.tongsuan.cn 
 

14) 切换到 Identification 页面，双击 Longitudinal control torque 右边的单

元格，选择转向架子系统里的参数符号 m_control，并在下方 Gain 右边

的单元格将参数设置为 3000。 

 

图 3-102 

15) 切换到 Geometry, irregularities 页面，勾选 Use irregularities，设置轨道

线路“D:\UM 培训教程\曲线素材\R300.mcg”，设置路面不平度如图 

3-103，设置 Factor=0.5，勾选 Coherent right irregularities。 

 

图 3-103 
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16) 切换到 Identifiers→List of identifiers 页面，设置车辆初始速度 v0 为

40，在弹出窗口点击 OK。 

 

图 3-104 

17) 选择主菜单 Tools → Options，或直接在工具栏上修改车辆初始速度单

位为 km/h。这里的单位只对 v0 参数有效，计算结果均为国际单位

（m，rad ，kg，s，N）。 

 

图 3-105 
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18) 打开变量向导，创建前转向架四个走行轮的法向力变量，并拖入一个绘

图窗口。 

 

图 3-106 

20) 在模型动画窗口空白处点右键，选择菜单 Cameras → Add camera in 

current position, 再通过右键菜单 Cameras → Camera settings，在

Camera follows the body 可选择镜头跟随车体。 

   

图 3-107 

21) 点击仿真控制面板 Integration 按钮开始仿真。 
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22) 在动画窗口点击右键，选择 Show vectors for tyre/road interraction，可

显示轮胎力矢量。 

 

图 3-108 

23) 在绘图窗口点右键，选择菜单 Show all，可自动调节以适应窗口。 

 
图 3-109 

24) 仿真过程如图 3-110，如果将动画窗口最小化或关闭，计算会非常快。 

 

图 3-110 
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3.3  磁浮交通 

 
图 3-111 

图 3-111 所示为一个典型的高速磁浮车辆模型，该模型由一个车体和六个悬

浮架子系统组成。其中悬浮架子系统里有一个构架、两个悬浮电磁铁和两个导向电

磁铁，每个电磁铁上有四个加速度传感器，电磁铁与构架之前有一系悬挂，车体和

构架之间有二系悬挂，模型共计 114 个自由度。 

本例用到的模块：UM Base、UM Subsystem、UM Maglev。 
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3.3.1 高速磁浮车辆动力学建模 

3.3.1.1  刚体与铰 

1) 运行 UM Input，新建模型，保存为“D:\UM 培训教程\我的 UM 模型\高

速磁浮车辆模型”。 

2) 从“D:\UM 培训教程\几何素材\高速磁浮车辆模型”依次导入建模所需

的几何素材构架.img，悬浮电磁铁.img，导向电磁铁 img，空气弹

簧.img。 

 

图 3-112 

3) 将导向电磁铁几何重命名为导向电磁铁 L，新建一个几何，重命名为导

向电磁铁 R，选择类型 GO，从下拉菜单中选择几何导向电磁铁 L，在

GO Position 页面设置绕 Z 轴旋转 180°。 

    

图 3-113 
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4) 创建第一个刚体，命名为构架，选择几何构架，定义质量参数 m_frame 

= 1000，转动惯量（1000，1000，1000），质心坐标为（0，0，0）。 

 

图 3-114 

5) 创建第二个刚体，命名为悬浮电磁铁 L，选择几何悬浮电磁铁，定义质

量 m_magnet = 600，转动惯量（20，600，600），质心坐标（0，0，-

0.25）。 

 

图 3-115 

6) 复制刚体悬浮电磁铁 L，重命名为悬浮电磁铁 R。 

7) 复制刚体悬浮电磁铁 R，重命名为导向电磁铁 L，选择几何导向电磁铁

L，修改质心坐标（0，0.08，0）。 

8) 复制刚体导向电磁铁 L，重命名为导向电磁铁 R，选择几何导向电磁铁

R，修改质心坐标（0，-0.08，0） 

9) 创建第一个铰，Body1 选择 Base0，Body2 选择构架，类型为 6 d.o.f.，

铰点坐标都为各自的原点，无需修改。 
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图 3-116 

10) 创建第二个铰，Body1 选择构架，Body2 选择悬浮电磁铁 L，类型为 6 

d.o.f.，两个物体铰接点坐标分别为（0，1.1，-0.475）和（0，0，0），悬

浮电磁铁相对构架具有沿 X、Z 轴平动及绕 Y 轴转动的自由度。 

 

图 3-117 

11) 复制生成第三个铰，Body2 更改为悬浮电磁铁 R，Body1 的铰接点坐标

为（0，-1.1，-0.475）。 
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12) 复制生成第四个铰，Body2 更改为导向电磁铁 L，Body1 的铰接点坐标

为（0，1.465，-0.18），导向电磁铁相对构架具有沿 X、Y 轴平动及绕 Z

轴转动的自由度。 

 

图 3-118 

13) 复制生成第五个铰，Body2 更改为导向电磁铁 R，Body1 的铰接点坐标

为（0，-1.465，-0.18）。切换到整体视图模式，如图 3-119。 

 

图 3-119 
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3.3.1.2  悬挂力元 

1) 选中左侧模型树 Special forces，点击右侧按钮 ，添加一个力元，命名

为悬浮电磁铁 LF，选择类型 Bushing，Body1 选择构架，Body2 选择悬

浮电磁铁 L，勾选 Autodetection，在 Position | Body1 界面设置连接点

(1，1.1，-0.8)。 

 
图 3-120 

2) 在 Description 页面设置线性刚度 CX = 5e6，CZ = 5e6，CAY = 1e5，DX 

= 5e4，DZ = 5e4，DAY = 1e3，定义初始悬浮力 FZ = -fz1，缺省赋值

0。 

3) 在左侧下方的参数列表窗口，双击参数符号 fz1，定义表达式：

9.81*(m_carbody/n_bogies+m_frame+2*m_magnet)/4，程序会自动创建

m_carbody 和 n_bogies 两个符号，分别输入数值 15000 和 6。 

 
图 3-121 
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4) 复制生成第二个 Bushing 力元，命名为悬浮电磁铁 LR，修改 Body1 的

连接点坐标为（-1，1.1，-0.8）。 

5) 复制生成第三个 Bushing 力元，命名为悬浮电磁铁 RR，将 Body2 更改

为悬浮电磁铁 R，修改 Body1 的连接点坐标为（-1，-1.1，-0.8）。 

6) 复制生成第四个 Bushing 力元，命名为悬浮电磁铁 RF，修改 Body1 的

连接点坐标为（1，-1.1，-0.8）。 

7) 复制生成第五个 Bushing 力元，命名为导向电磁铁 LF，将 Body2 更改

为导向电磁铁 L，修改 Body1 的连接点坐标为（1，1.6，-0.18）。 

 

图 3-122 

8) 在 Description 页面设置线性刚度 CX = 5e6，CY= 5e6，CAZ = 1e5，DX 

= 5e4，DY = 5e4，DAZ = 1e3，定义初始导向力 FY = fy0*1000，设置

fy0 初值为 5。 

 

图 3-123 
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9) 复制生成第六个 Bushing 力元，命名为导向电磁铁 LR，修改 Body1 的

连接点坐标为（-1，1.6，-0.18）。 

10) 复制生成第七个 Bushing 力元，命名为导向电磁铁 RR，将 Body2 更改

为导向电磁铁 R，修改 Body1 的连接点坐标为（-1，-1.6，-0.18），修改

横向预压力 FY = -fy0*1000。 

11) 复制生成第八个 Bushing 力元，命名为导向电磁铁 RF，修改 Body1 的

连接点坐标为（1，-1.6，-0.18）。 

12) 选中左侧模型树 Linear forces，点击右侧按钮 ，创建第一个空气弹簧

力元，命名为空气弹簧 LF，Body1 选择构架，Body2 选择 External，选

择几何空气弹簧，勾选 Automatic computation for 2nd body，输入弹簧

下点和上点坐标（0.8，1.2，0.6）和（0.8，1.2，0.9）。 

 

图 3-124 

13) 在 Parameters 页面，定义弹簧预压力 fz2，回车，点击 Accept，然后到

左侧参数列表双击 fz2，在弹出窗口定义表达式：

m_carbody*9.81/n_bogies/4。 

 

图 3-125 
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14) 点击 Stiffness matrix 栏的按钮，输入刚度矩阵，如图 3-126，其中

kxy_2 为纵向和横向刚度（1e4），kz_2 为垂向刚度（2e5）。 

 

图 3-126 

15) 点击 Damping matrix 栏的按钮，输入阻尼矩阵，如图 3-127，其中 cxy_2

为纵向和横向阻尼（2e3），cz_2 为垂向阻尼（3e3）。 

 

图 3-127 

16) 复制生成第二个空气弹簧力元，命名为空气弹簧 LR，修改弹簧下点和上

点坐标（-0.8，1.2，0.6）和（-0.8，1.2，0.9）（。 

17) 复制生成第三个空气弹簧力元，命名为空气弹簧 RR，修改弹簧下点和

上点坐标（-0.8，-1.2，0.6）和（-0.8，-1.2，0.9）。 

18) 复制生成第四个空气弹簧力元，命名为空气弹簧 RF，修改弹簧下点和上

点坐标 0.8，-1.2，0.6）和（0.8，-1.2，0.9）。 

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 156 -             www.tongsuan.cn 
 

 

图 3-128 

19) 选中左侧模型树 Contact forces，点击右侧按钮 ，创建一个接触力

元，Body1 选择构架，Body2 选择 Base0，选择类型 Point-Plane，定义

Body1 的某些点与 Body2 的某平面有接触关系。 

20) 在 Parameters 页面设置动摩擦系数 0.3，静摩擦系数 0.36，接触刚度

1e8，接触阻尼 1e4，勾选单侧接触 Unilateral contact 和无限平面

Unlimited plane。 

 
图 3-129 
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21) 在 Geometry 页面，定义 Body1 的点：（0.8，1.1，0.02），（0.8，-1.1，

0.02），（-0.8，-1.1，0.02）和（-0.8，1.1，0.02），定义 Body2 的平面：

通过点（0，0，0）法向为（0，0，1）。 

 

图 3-130 
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3.3.1.3  加速度传感器 

1) 选中左侧模型树 Subsystems，点击右侧按钮 ，添加一个子系统，重命

名为垂向传感器 LF，从下拉菜单中选择 Included，然后在文件浏览器中

选择“D:\UM 培训教程\子系统\传感器”。 

 
图 3-131 

2) 将子系统垂向传感器 LF 复制七次，分别重命名为垂向传感器 LR、垂向

传感器 RR、垂向传感器 RF、横向传感器 LF、横向传感器 LR、横向传

感器 RR 和横向传感器 RF，并将四个横向传感器里的 p0 设置为 0。 

 

图 3-132 
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3) 创建第六个铰，Body1 选择悬浮电磁铁 L，Body2 选择垂向传感器

LF.Sensor，类型为 6 d.o.f.，两个物体铰接点坐标分别为（1，0，-0.01）

和（0，0，0），约束其六个自由度。 

   
图 3-133 

4) 复制生成第七个铰，更改 Body2 为垂向传感器 LR.Sensor，修改 Body1

的连接点坐标为（-1，0，-0.01）。 

5) 复制生成第八个铰，更改 Body1 为悬浮电磁铁 R，更改 Body2 为垂向传

感器 RR.Sensor，Body1 的连接点坐标为（-1，0，-0.01）。 

6) 复制生成第九个铰，更改 Body2 为垂向传感器 RF.Sensor，修改 Body1

的连接点坐标为（1，0，-0.01）。 

7) 复制生成第十个铰，更改 Body1 为导向电磁铁 L，更改 Body2 为横向传

感器 LF.Sensor，修改 Body1 的连接点坐标为（0.9，0.03，0），设置绕

X 轴转动 90°。 

 

图 3-134 
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8) 复制生成第十一个铰，更改 Body2 为横向传感器 LR.Sensor，修改

Body1 的连接点坐标为（-0.9，0.03，0）。 

9) 复制生成第十二个铰，更改 Body1 为导向电磁铁 R，更改 Body2 为横向

传感器 RR.Sensor，修改 Body1 的连接点坐标为（-0.9，-0.03，0），设

置绕 X 轴转动-90°。 

10) 复制生成第十三个铰，更改 Body2 为横向传感器 RF.Sensor，修改

Body1 的连接点坐标为（0.9，-0.03，0），切换到完整视图，如图 

3-135。 

 
图 3-135 
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3.3.1.4  磁浮力元 

1) 选中左侧模型树 Special forces，点击右侧按钮 ，添加一个力元，命名

为悬浮力 LF，选择类型 Maglev force，Body1 选择悬浮电磁铁 L，

Body2 选择 Base0，设置作用点（1，0，0），选择悬浮力 Leviation 

magnet，作用方向为 Z 轴正向（0，0，1），选择传感器垂向传感器

LF.a_sensor，定义垂向悬浮力 FZ_LF，赋初值 0 即可。 

 

图 3-136 

2) 复制生成第二个悬浮力，命名为悬浮力 LR，作用点（-1，0，0），选择

传感器垂向传感器 LR.a_sensor，定义垂向悬浮力 FZ_LR。 

3) 复制生成第三个悬浮力，命名为悬浮力 RR，更改 Body1 为悬浮电磁铁

R，作用点（-1，0，0），选择传感器垂向传感器 RR.a_sensor，定义垂

向悬浮力 FZ_RR。 

4) 复制生成第四个悬浮力，命名为悬浮力 RF，作用点（1，0，0），选择传

感器垂向传感器 RF.a_sensor，定义垂向悬浮力 FZ_RF。 
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5) 复制生成第一个导向力，命名为导向力 LF，更改 Body1 为导向电磁铁

L，作用点（0.9，0，0），作用方向为 Y 轴负向（0，-1，0），选择传感

器横向传感器 LF.a_sensor，定义横向导向力 FY_LF。 

 

图 3-137 

6) 复制生成第二个导向力，命名为导向力 LR，作用点（-0.9，0，0），选

择传感器横向传感器 LR.a_sensor，定义横向导向力 FY_LR。 

7) 复制生成第三个导向力，命名为导向力 RR，更改 Body1 为导向电磁铁

R，作用点（-0.9，0，0），作用方向为 Y 轴正向（0， 1，0），选择传感

器横向传感器 RR.a_sensor，定义横向导向力 FY_RR。 

 

图 3-138 

8) 复制生成第四个导向力，命名为导向力 RF，作用点（0.9，0，0），

选择传感器横向传感器 RF.a_sensor，定义垂向悬浮力 FY_RF。  

http://www.universalmechanism.com/


                                                                               

www.universalmechanism.com         - 163 -             www.tongsuan.cn 
 

3.3.1.5  整车装配 

1) 左侧选中模型树 Object，在右侧 General 页面点击按钮 Transform into 

subsystem，这样就把一个悬浮架模型压缩成了一个子系统，便于整体操

作。 

 

图 3-139 

2) 重命名为悬浮架 1，在 Position 定义 X 平动-2-2.9*0.5m。 

 

图 3-140 

3) 将子系统悬浮架 1 复制五次，分别重命名为悬浮架 2、悬浮架 3、悬浮架

4、悬浮架 5 和悬浮架 6，Position 分别定义 X 平动为-2-2.9*1.5 m、-2-

2.9*2.5 m、-2-2.9*3.5 m、-2-2.9*4.5 m 和-2-2.9*5.5 m。 
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4) 从“D:\UM 培训教程\几何素材\高速磁浮车辆模型”导入几何素材车

体。 

5) 在左侧参数符号列表区点右键，选择菜单 Add from subsystem…，从列

表中选择悬浮架 1 子系统里的 m_frame、m_magnet、m_carbody 和

n_bogies 参数。 

   

图 3-141 

6) 创建车体刚体，定义质量 m_carbody，转动惯量（5e4，3e5，3e5），质

心坐标（-10.7，0，1. 5）；点击按钮 ，创建一个六自由度铰。 

   

图 3-142 
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7) 然后，我们需要将车体和六个悬浮架子系统建立连接。在二系力元建模

时，还没有车体这个物体，因此所有的 Body2 都选择为一个虚拟物体

External，两个连接点的坐标都在 Body1 坐标系中定义的。在左侧模型

树选中 Connection，到右侧交互界面选中任意一个力元，点右键，选择

Assign to all，然后选择车体局部坐标系的原点（实际车体上的任意点均

可），这样就用车体替换了子系统里的 External 虚拟体。 

 

图 3-143 

       

图 3-144 
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8) 为了便于后期仿真控制，我们在这里单独定义一个名义悬浮力 fz0 

= 9.81*(m_carbody/n_bogies/4+m_frame/4+m_magnet)/1000。 

 

图 3-145 

9) 最后，在左侧模型树选中 Object，右侧 General 界面 Comments 处输入

备注 Monorail（如果模型中无轮胎力元，这一步可略去）。 

 
图 3-146 

10) 点击 Summary，检查是否有逻辑错误，保存模型，关闭 UM Input 程

序。 
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3.3.2 高速磁浮车辆动力学仿真 

1) 运行 UM Simulation 程序，加载高速磁浮车辆模型。自由调整动画窗口

大小、位置和视图方向。 

 

图 3-147 

2) 打开仿真控制面板，选择 Park 求解器，设置仿真时间 30s，设置数据采

样步长为 0.005s，容差为 1e-7，勾选 Computation of Jacobian。 

 
图 3-148 
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3) 切换到 Monorail train → Tools 页面，从下拉菜单选择 Beam section 

profile。然后点击 Data Input/Edit 栏的 按钮，弹出曲线编辑器，点击

曲线编辑器工具栏按钮 ，读取“D:\UM 培训教程\曲线素材”路径下

的高速磁浮轨道梁.crv 文件。 

  

图 3-149 

4) 切换到 Geometry, irregularities 页面，设置轨道线路和不平顺等参数如

图 3-150。 

 

图 3-150 
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5) 切换到 Maglev→Levitation 页面，选择悬浮控制模型 Spring/Damper，

并设置名义悬浮间隙 10mm，名义悬浮力 fz0=14.46975 （可双击单元格

从符号列表读取），电磁铁控制质量 300kg，位移反馈系数 1e8N/m，速

度反馈系数 1e4 Ns/m。 

 

图 3-151 

6) 切换 Maglev→Guiding 页面，设置如图 3-152。 

 
图 3-152 
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7) 切换到 Speed 页面，选择 v=0 模式。 

 

图 3-153 

8) 点击 Integration，进行静平衡计算，经过 1s，提示“Test succed. Accept 

results?”，点击是(Y)。 

 

图 3-154 
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9) 切换到 Speed 页面，选择 v=const 模式。 

10) 切换到 Identification 页面，在下方 Gain 右边的单元格将参数设置为

5000。 

 

图 3-155 

11) 切换到 Identifiers→List of identifiers 页面，设置车辆初始速度 v0 为

40，在弹出窗口点击 OK。 

 
图 3-156 
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12) 选择主菜单 Tools → Options，或在工具栏上修改车辆初始速度单位为

km/h。这里的单位只对 v0 参数有效，计算结果均为国际单位（m，

rad ，kg，s，N）。 

 

图 3-157 

13) 打开变量向导，在 Maglev forces 页面，设置长度单位 mm，创建第一个

悬浮架的四个悬浮力的悬浮间隙变量 Gap，并拖入一个绘图窗口。 

 
图 3-158 
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14) 在 Maglev forces 页面，设置力的单位 N，创建第一个悬浮架的四个悬浮

力的悬浮力矢量 Fv，并拖入动画窗口。 

 

图 3-159 

15) 在动画窗口空白处点右键，选择 Position of vector list → Left，这样就

在动画窗口左侧显示列表。 

 

图 3-160 
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16) 双击悬浮力矢量 Fv，修改颜色。 

 

图 3-161 

17) 在动画窗口点右键，选择 Vector seting，设置力矢量单位长度表示的大

小为 15000，在 Size 页面可以调节箭头大小。 

 
图 3-162 
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18) 在模型动画窗口点右键，选择菜单 Cameras → Add camera in current 

position，再选择右键菜单 Cameras → Camera settings → Camera1，

在 Camera follows the body 可选择镜头跟随车体。 

      

图 3-163 

19) 点击仿真控制面板 Integration 按钮开始仿真。 

20) 在绘图窗口点右键，选择菜单 Show all，可自动调节以适应窗口。 

 
图 3-164 
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21) 仿真过程如图 3-165，如果将动画窗口最小化或关闭，计算会非常快。 

  

图 3-165 

注：读者可以选择软件自带的单极电磁铁控制模型或自定义控制模型

（Matlab/Simulink、UM Block Editor）进行仿真计算。 
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